Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesMonday, June 25, 2018
Navigation
Home
Articles
Downloads
Hobby Wear
FAQ
Forums
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Search
Users Online
Guests Online: 6
No Members Online

Registered Members: 7,146
Newest Member: bhamakripa
PdfFactory Pro Enterprise 2.31, MATFOR 4.00.061031 in Lahey Fortran, Adobe PhotoShop 9.0 CS2 oem, Trend Micro InterScan VirusWall 6.0, Adobe Acrobat 7.0 Professional sale, Salon Iris 5.05, Drafix Pro Landscape 11.2, oem Adobe PhotoShop CS 8.0 cheap buy, Catia 5 R12 P3 with SP2, Mcafee Secure Internet Gateway 4.5, oem Adobe Acrobat Professional 8 oem, Visual UML 4.1 Developer Edition, sale Adobe CS3 Design Premium Vol for Mac low price, Nuance Dragon Naturally Speaking 9.0 Professional With SP1, Adobe After Effects Plugins, low price AutoCAD 2006 cheap buy, Avid NewsCutter XP 3.8, The Movie Library 1.7.11, oem Adobe Creative Suite Premium Edition 2.0, ProFlyers 6.0 PDF Forms for Adobe Acrobat, PTC Pro Engineer Routed Systems Designer 5.0, sale DVDXCopy Platinum 4.0.38, CyberBizPlan v1.0.165 WinAll, NeverCenter Silo 1.16b, cheap buy AutoCAD 2005, Norton Save And Restore 11, sale Adobe Creative Suite 3 Design Premium sale, Adobe Premiere Plugins Collection 2007, cheap buy Adobe Creative Suite Premium Edition 2.0 for Mac sale, Active Desktop Calendar 6.5.061124, sale Adobe Acrobat 6.0 Professional, X-Rite MonacoPROFILER Platinum 4.8, EmailUnlimited 6.1 Win98NTME, oem Adobe Photoshop CS3 Extended sale
Sponsors
Island Computer
View Thread
OpenVMS Hobbyist Program | Alpha Systems Forums | FreeAXP
Author Anyone have any luck getting DECnet and UCX working on the same system?
dherrick
Member

Posts: 3
Joined: 22.04.10
Posted on May 07 2010 12:36
I have FreeAXP loaded on a BL680c G5 server. Host OS is Windows Server 2008 R2 64-bit. I created a 4.0 Gig DK100 virtural disk for the OS in the FreeAXP config file. Wasn't able to load the OS from the OpenVMS 8.3 Alpha CD, using the shared DVD that comes with the c3000 Blade enclosure. I attached it to the BL680 from the enclosure's console, loaded the install CD, created the DKA0 CD device in the FreeAXP config file, but it wasn't recognized. Luckily, I was able to create a bit for bit copy of the VMS OS load CD, using one of those ISO utilities and installed VMS from a CD image file instead. The install went fine. I added an additional network port in the FreeAXP config file and an 80 Gig hard drive for data. Now I have an EWA0 and an EWB0 network device and a nice fat DK200 drive. I selected the ODS2 filesystem rather than ODS5 and DECnet Phase IV rather than DECnet Phase V, during the install. I'm going to be doing DECnet file copies from very old DEC systems over to the emulater via DECnet and I wanted the emulator to match the client environment as much as possible. I ran netconfig.com to set up DECnet. Then, I ran tcpip$config.com to setup TCPIP Services. Telnets work fine between systems. I can DECnet set host to myself, but out-going set hosts fail with the "node is not currently reachable" error. I wanted to run DECnet on EWA0 only, so I removed EWA1 from the config. And I wanted to run IP networking on EWA1 only. I'm still trying to figure out how to remove WE0 from the TCPIP config. I even tried going into Windows network properties and unchecking boxes to prevent the host system from using certain network ports. I believe I added all the necessary licenses and created all the necessary nodes in the network database, but set host fails. I did an mcr ncp show known nodes on the system I'm trying to set host to and it says my emulated system is reachable and there's a next node listed. When I do an mcr ncp show known nodes on my emulated system, it doesn't say the target node is reachable and there is no next node listed, just 0. This looks like a problem. I've tried all available network ports and I even tried setting the mac to AA-00-04-00-E6-07 in the FreeAXP config file. Still no luck. I'm going to try a few more things. Has anyone had any luck running DECnet and TCPIP on the same emulated system? I'm only half way there. My next step is to load CIFS for VMS. When I'm done the DECnet files I'm moving will need to be copied over to a Windows Sever. This system will be a file staging area and a gateway to Windows. My only other alternative is to buy an Integrity Server and use a real system rather than an emulated system. Even if I bought the Integrity on ebay it's going to cost big bucks. I have the BL680 on loan. The eventual target will probably be a cheap Pollywell Mini-ITX based system.

Dennis Herrick
[email protected]
Author RE: Anyone have any luck getting DECnet and UCX working on the same system?
Bruce Claremont
Moderator

Posts: 502
Joined: 07.01.10
Posted on May 07 2010 14:58
We use DECnet and TCP/IP together on most of our test beds. Ensure DECnet is starting before TCP/IP. The best way to accomplish this is to put both inline in SYSTARTUP_VMS.COM instead of letting them submit to batch queues during the start up process.

I've also found that if DECnet or TCP/IP do not successfully start, they sometimes lose their settings. To get around this, I do the following:

1) Disable DECnet and TCP/IP startups in SYSTARTUP_VMS.COM

2) Reboot.

3) Configure DECnet and re-enable it's startup call in SYSTARTUP_VMS.COM.

4) Reboot and test DECnet.

5) Configure and re-enable TCP/IP startup call in SYSTARTUP_VMS.COM.

6) Reboot and test.
Edited by Bruce Claremont on August 31 2010 16:22
Author RE: Anyone have any luck getting DECnet and UCX working on the same system?
VolkerHalle
Member

User Avatar

Posts: 96
Location: Germany
Joined: 02.04.10
Posted on May 07 2010 22:02
Dennis,

OpenVMS is OpenVMS is OpenVMS, whether you run it on FreeAXP, PersonalAlpha or any real Alpha. The same system management and troubleshooting principles apply.

Communication with the 'outside world' is special, because it also requires the components connecting to the network to behave correctly, in case of hardware emulation, this then also involves the host operation system and drivers and maybe even the communications gear at the end of the simple network cable.

Simple answer first: to remove WE0 from your TCPIP configuration, use $ TCPIP SET CONF NOINT WE0

Some background:

When starting DECnet Phase IV protocols on a LAN adapter, OpenVMS changes the MAC address of the LAN adapter to it's DECnet MAC address: AA-00-04-00-xx-yy, where xx-yy is calculated from the DECnet address (area.node). This is an operation, which 'other' operating systems and network components may have some problems with...

The emulator emulates a LAN interface, so - in general - it doesn't care about the protocols being used on that LAN interface. But the communication stack between the emulator and the real LAN interface is quite complicated and not easily diagnosable.

A DECnet node can be configured as an Endnode or as a Router. Only a router will show other nodes as 'reachable'. DECnet endnodes and routers send DECnet multicast hello messages on the LAN (endnodes to all routers and routers to all endnodes). It is not required to have a router on a LAN. If an endnode does not see a router, it will just send out the packet on the LAN to the Phase IV address to the destination node. If there is no response, you get the UNREACHABLE error, but NOT immediately (should take about 60 seconds = outgoing timer). If you get an immediate UNREACHABLE error, there is either no active circuit or the adjacent router did not know how the reach the destination node.

There is absolutely no reason for having to use different interfaces for DECnet and TCPIP, you don't consider to do that on a real Alpha, do you ? If you are using this 'workaround', this may indicate, that your LAN drivers in the host system may have a problem with changing of the MAC address.

Volker.

PS: see a recent discussion in the VAX Software forum (DECNET--> SET HOST one way only) for a similar discussion.
http://www.invenate.de
Author RE: Anyone have any luck getting DECnet and UCX working on the same system?
astrodanco
Member

Posts: 36
Joined: 04.03.10
Posted on May 10 2010 10:07
No problem getting DECnet IV and TCP/IP working together nicely here. Heck, even inbound and outbound LAT work. Ethernet clustering also works. In fact, I haven't found a darned thing that doesn't work. That's highly unusual. smiley

Per the FreeAXP release notes, I use one TAP adapter per emulated or virtual machine, then bridge them all with the real adapter. This works very well.
Author RE: Yeah! Yeah! Yeah!
dherrick
Member

Posts: 3
Joined: 22.04.10
Posted on June 09 2010 11:21
I found the problem and it had absolutely nothing to do with FreeAXP.
Way way back 12 or 13 years ago when we had Netware, TCP/IP and DECnet running on the same network, we eventually discovered that we needed to isolate Netware broadcasts traffic from DECnet so the VAX Cluster satellites could boot quickly. Back then we had Cabletron switches and a Cabletron backbone. We had Extreme Networks come in and replace the Cabletron backbone. Then we set up TCPIP-only ports on some of the Cabletron switches, DECnet-only ports on some switches and shared DECnet / TCP/IP ports on some switches. Over time we phased out Netware. I thought all the Cabletron stuff was replaced 5 years ago with SMC and Netgear switches, but some of the old infrastructure must still remain. Well I tried to get FreeAXP to do DECnet from 3 or 4 locations in the building with no luck. Turns out all my test ports were TCP/IP-only. I could "set host" to myself, but not to anything in the outside world. So, I decided to take over a port used by one of the remaining VAX Satellite. If Decnet was going to work anywhere it had to work there. And DECnet worked perfectly. Case closed.

Dennis Herick
Jump to Forum:
Login
Username

Password



Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?

Yes

No

You must login to vote.
Shoutbox
You must login to post a message.

bhamakripa
June 24 2018
I am trying OpenVMS via SIMH. Need to get OS binaries for v7.3. Registered here but don't have any membership number yet which is needed to get license. Pls suggest what to do. I hardly know anyth

basilh
June 05 2018
Any other forum members in Perth, Australia?

LouF91
April 05 2018
ah maybe they love that!

malmberg
March 24 2018
Probably. More people hang out on the comp.os.vms newsgroup.

vaxpert
March 23 2018
I have a PE42A and other Alpha system stuff for sale. I'm in So California. Any interest out there?

goodbyespy
February 27 2018
To Prohorenko. Please, visit group OpenVMS in the ok.ru

peteherrera
February 24 2018
How much does it cost to buy a complete OpenVMS hardcopy documentation set of the latest version

prohorenko
February 17 2018
Please help to obtain the license on OpenVMS

malmberg
December 12 2017
HPE only makes the most current version of OpenVMS Alpha / IA64 /VAX available to hobbyists. When I had access to the Alliance 1 program it was the same. No public downloads are allowed by HPE.

nmbonao
December 08 2017
Is anybody knows OpenVMS 8.2 version downloadable version? or CD copy? Thank you very much

aarommes
December 02 2017
Bitcoin and Blockchain enthusiasts ( plus distributed computing ) please connec / reply: http://www.openvmshobbyis
t.com/forum/viewthread.ph
p?forum_id=130&thread_id=
2991


malmberg
September 10 2017
https://sourceforge.net/p
/vms-ports/wiki/VMSInstal
lation/ For the most part just use VMS 6.1 media instead of 7.3. But why run the older release?


DoeveR
August 07 2017
Where can I find the write up on running VMS 6.1 using the simh emulator?

Bart
March 20 2017
Happy to have found my password again!

pintero
March 16 2017
peteherrera. Agreed.

Shoutbox Archive