Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesFriday, January 28, 2022
Navigation
Home
Articles
Downloads
Hobby Wear
FAQ
Forums
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Search
Users Online
Guests Online: 15
No Members Online

Registered Members: 7,623
Newest Member: alleahmarcina30
Sponsors
Island Computer
View Thread
OpenVMS Hobbyist Program | Alpha Systems Forums | FreeAXP
Author freeAXP/Avanti build 653 and 653a - problems updating from 649
rspalding
Member

Posts: 7
Location: Southern NJ
Joined: 19.08.08
Posted on December 23 2020 09:00
I'm running VSI community distro v8.4-2L1, formerly successfully on build 649,
on Windows 10 pro, build 19042.685.

I noticed the new 653 build. I attempt to install 653, replacing 649.
All kinds of trouble ensues.

When I first started the configurator after the upgrade, it hangs upon loading the pre-existing configuration. I believe that this was a 'hard' hang, in which i could not forcibly terminate the process from windows task manager. When I attempted to reboot Windows, the reboot also hangs.

After hitting the RESET button, I started the configurator and this time, the configurator process does not hang; however, when I attempted to start the emulator process, dec.exe, the emulator process hangs, again in such a way that it cannot be terminated, and reboot required pressing RESET.

After this, I reverted to build 649, which fortunately still works.

Today, I notice that a new build 653a has appeared, so I tried again. This time I used control panel to remove the broken version, rebooted, installed 653a, rebooted again, prior to starting the configurator. This time, the config file loads without a process hang, but dec.exe, when started, still immediately enters a hung state (no CPU time charged). Again, I cannot use Task Manager to terminate the process. First attempt is accepted silently, subsequent ones return an 'Access is denied' pop-up. I haven't tried system reboot yet, but I expect the same behavior as before.

This system has no other applications that use an NDIS shim (*pcap), so no conflicts should arise. I am running with only a single NIC - which has been trouble-free until now.

I plan next to reboot again, and create a new configuration file from scratch, to see if anything changes.

Frustration: Why, oh why, can't this thing 'just work' ?
Author RE: freeAXP/Avanti build 653 and 653a - problems updating from 649
rspalding
Member

Posts: 7
Location: Southern NJ
Joined: 19.08.08
Posted on December 23 2020 09:18
Sorry, I fibbed one little bit above; this system does have 2x NIC installed. The one used in the pre-existing configuration is named 'Ethernet 2'.

Also note that yet again, rebooting Windows required use of the RESET button.

After the reboot, I created a new configuration file - which results in unchanged behavior; dec.exe process is still hung, and can't be terminated.

I checked to see which version of msipcap was installed in \windows\system32\drivers, and it IS the one supplied by 653.
Author RE: freeAXP/Avanti build 653 and 653a - problems updating from 649
Bruce Claremont
Moderator

Posts: 606
Joined: 07.01.10
Posted on December 24 2020 05:09
Is Winpcap installed on the system? If so, remove it. It conflicts with msipcap. If you need Winpcap functionality, switch to Npcap.
Author RE: freeAXP/Avanti build 653 and 653a - problems updating from 649
rspalding
Member

Posts: 7
Location: Southern NJ
Joined: 19.08.08
Posted on December 30 2020 19:47
The problem has been solved.

It appears that Winpcap is a thing that just won't die. I found it on two of my systems that run freeAXP. Winpcap didn't appear to cause problems with build 649, but it's fatal to 653.

At issue with Winpcap is that once it's installed, typically by a dependent product, it doesn't necessarily get removed when said product is removed - after which, Winpcap doesn't necessarily show up on the Control Panel 'Programs and Features' panel.

I solved the problem by renaming three files; packet.dll and wpcap.dll (in \windows\system32\smiley, and npf.sys (in \windows\system32\drivers\smiley, so they would not be found by Windows during system startup.

I had also tried INSTALLING Winpcap over itself, with the intent of trying to remove same afterwards - this failed because some of the pre-existing files couldn't be replaced by the installer.

It would be helpful if the freeAXP installer could alert the user to the presence of Winpcap.
Author RE: freeAXP/Avanti build 653 and 653a - problems updating from 649
Bruce Claremont
Moderator

Posts: 606
Joined: 07.01.10
Posted on December 31 2020 03:57
I am glad you were able to resolve the issue. FreeAXP 653 addresses this in two ways:

- The FreeAXP log file indicates the pcap driver in use. Search on "pcap" to find the relevant lines.

- msipcap is now the default NDIS driver. If npcap use is desired, the use_npcap_driver option must be enabled in the configuration file. See the FreeAXP User Guide and Release Notes for details.

These changes do not address older implementations of Winpcap. Winpcap 4.1.3 has always interfered with FreeAXP's NDIS driver. A change in Windows broke compatibility with Winpcap 4.1.2 and older versions. These issues are addressed in the FreeAXP Release Notes. The short answer is: Replace Winpcap with Npcap.
Jump to Forum:
Login
Username

Password



Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?

Yes

No

You must login to vote.
Shoutbox
You must login to post a message.

parwezw
January 03 2022
Anyone know what happened to FAFNER.DYNDS.ORG? I had a hobbyist account here but can longer access the site.

gtackett
October 27 2021
Make that DECdfs _2.1A_ for Vax

gtackett
October 27 2021
I'm looking for DECdfs V2.4A kit for VAX. Asking here just in case anyone is still listening.

MarkRLV
September 17 2021
At one time, didn't this web site have a job board? I would love to use my legacy skills one last time in my career.

malmberg
January 18 2021
New Hobbyist PAKs for VAX/VMS are no longer available according to reports. Only commercial licenses are reported to be for sale from HPE

dfilip
January 16 2021
Can someone please point me to hobbyist license pak? I'm looking for VAX/VMS 7.1, DECnet Phase IV, and UCX/TCPIP ... have the 7.1 media, need the license paks ... thanks!

Bart
October 16 2020
OpenVMS, and this website!

malmberg
September 05 2020
VSI community non-commercial licenses for AXP/IA64 are available now.

malmberg
September 05 2020
See the forum about licensing. Don't know if HPE hobby licenses still being issued. Commercial licenses still being sold.

silfox70
September 01 2020
I need the license for OpenVMS7.3. Where can I find them?

malmberg
August 29 2020
Eisner, which is currently being moved, got an SSH update and the keys were updated to more modern encryption standards.

jiml
July 11 2020
ssh to eisner is now giving (on linux) "WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!" , Has the server key in fact changed ? Of WHO can we ask that somewhere on the eisner webpage they

wyan
May 06 2020
Turns out I had an account here, it still was set to my location a decade ago, so hey, I'm back after over a decade!

Hein
April 21 2020
Hi all, haven't been here in years. Good to see it is all there still. I'm looking around at the forum to stop/start msipcap - 'could not be stopped' - for now. I'll shutdown FreeA

EstesDave
January 09 2020
does anyone have or know of DRB32 manuals

Shoutbox Archive