Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesMonday, January 21, 2019
Navigation
Home
Articles
Downloads
Hobby Wear
FAQ
Forums
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Search
Users Online
Guests Online: 5
No Members Online

Registered Members: 7,248
Newest Member: alishapatel01
Sponsors
Island Computer
View Thread
OpenVMS Hobbyist Program | Alpha Systems Forums | FreeAXP
Author Networking between host and emulated Alpha
MartinW
Member

Posts: 5
Joined: 18.03.10
Posted on March 19 2010 10:39
I've followed the instructions in the release notes (for working with a single NIC and with a wireless card) and have got to the stage where both my host laptop and emulated Alpha can ping my router but they cannot ping each other.

They can also both ping another machine on my network (and I can telnet into the Alpha from here).

What have I missed?

Host - HP/Compaq nc8430 (dual core), XP Pro, 3GB. My network is wireless.
Emulated Alpha - VMS v7.3-2 (unpatched), UCX v5.4, DECnet not configured.

Thanks
Martin
Author RE: Networking between host and emulated Alpha
Bruce Claremont
Moderator

Posts: 508
Joined: 07.01.10
Posted on March 19 2010 16:26
Go to the hardware NIC in network properties and uncheck all options under the General tab, this connection uses the following items:. Then be sure the hardware NIC is assigned to FreeAXP in the configuration Wizard and reboot the emulator.

What's probably happening is Windows is still using the hardware NIC as it's primary NIC. Hence your telnet is running on the same NIC as the emulator. Disabling TCP/IP on the hardware NIC will force Windows to use the wireless NIC.

The same problem can occur on a system with dual NICs. Be sure the NIC assigned to FreeAXP has TCP/IP disabled in the NIC properties. Unchecking all options for the FreeAXP NIC guaranties the emulator has exclusive access to the device.

I'll post an update in the Release Notes. This is also covered in section 4.1 in the User Guide.
Author RE: Networking between host and emulated Alpha
MartinW
Member

Posts: 5
Joined: 18.03.10
Posted on March 22 2010 01:44
Bruce,

Thanks for your reply

I tried your suggestion without success - But I did find a solution...

I have configured the network bridge (as recommended in the release notes). Only on the bridged connection do I see the "This connection uses" menu. Unchecking all these meant that my PC could not see the outside world at all.

If I go to the wireless network connection, I don't see the "This connection uses" menu.

I tried unchecking various options and eventually ended up doing a reboot. Still no success.

So I put everything back as it was and found that the emulated system COULD ping the PC. But the PC could only PING the emulated system after the emulated system had PINGed it first.

So I thought the solution should be a very simple one - just add $ TCPIP PING <host system IP address> to SYSTARTUP_VMS.COM after TCPIP has been started.

But it's not quite that easy. That's fine ifsho you connect from the host to the emulated system within a few seconds of the PING but if you wait for a while, the PC seems to loose the route to the emulated system. (This happened in less than 2 but more that 1 minute on my system).

I tried playing with some of the TCP keepalives but without success. So Iíve put a batch job in place to PING the host interface every 60 secs.

Iím sure someone will be able to suggest a better way!

I hope this may help someone else!
Jump to Forum:
Login
Username

Password



Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?

Yes

No

You must login to vote.
Shoutbox
You must login to post a message.

jiml
November 09 2018
Thank you , Malmberg ! Exactly what I was hoping for . Reset key & all is well . JImL

malmberg
November 09 2018
Eisner was upgraded to the current Multinet Release. As part of that a new host key was generated. The old key was incompatible with newer Linux.

jiml
November 02 2018
ssh to eisner is now giving (on linux) "WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!" , Has the server key in fact changed ?

malmberg
June 26 2018
https://www.openvmshobbyi
st.com/forum/viewthread.p
hp?forum_id=10&thread_id=
2363


bhamakripa
June 24 2018
I am trying OpenVMS via SIMH. Need to get OS binaries for v7.3. Registered here but don't have any membership number yet which is needed to get license. Pls suggest what to do. I hardly know anyth

basilh
June 05 2018
Any other forum members in Perth, Australia?

LouF91
April 05 2018
ah maybe they love that!

malmberg
March 24 2018
Probably. More people hang out on the comp.os.vms newsgroup.

vaxpert
March 23 2018
I have a PE42A and other Alpha system stuff for sale. I'm in So California. Any interest out there?

goodbyespy
February 27 2018
To Prohorenko. Please, visit group OpenVMS in the ok.ru

peteherrera
February 24 2018
How much does it cost to buy a complete OpenVMS hardcopy documentation set of the latest version

prohorenko
February 17 2018
Please help to obtain the license on OpenVMS

malmberg
December 12 2017
HPE only makes the most current version of OpenVMS Alpha / IA64 /VAX available to hobbyists. When I had access to the Alliance 1 program it was the same. No public downloads are allowed by HPE.

nmbonao
December 08 2017
Is anybody knows OpenVMS 8.2 version downloadable version? or CD copy? Thank you very much

aarommes
December 02 2017
Bitcoin and Blockchain enthusiasts ( plus distributed computing ) please connec / reply: http://www.openvmshobbyis
t.com/forum/viewthread.ph
p?forum_id=130&thread_id=
2991


Shoutbox Archive