Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesMonday, November 29, 2021
Navigation
Home
Articles
Downloads
Hobby Wear
FAQ
Forums
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Search
Users Online
Guests Online: 1
No Members Online

Registered Members: 7,607
Newest Member: phatoes
Sponsors
Island Computer
View Thread
OpenVMS Hobbyist Program | Alpha Systems Forums | Alpha Software Forum
Author VMS 8.4 install on PW433au with EIDE ports
rattila
Member

Posts: 56
Location: Budapest
Joined: 11.08.17
Posted on October 18 2017 20:12
Hi,

I tried to install OpenVMS 8.4 from ATAPI CD drive to IDE disk.
The 1st part was successfull - I think - without any error messages.
I shutdown the system from the menu (choose menu 9).
After boot from hard disk I got this:

>>>boot dqb1
(boot dqb1.1.0.207.0 -flags 0,0)
block 0 of dqb1.1.0.207.0 is a valid boot block
reading 1230 blocks from dqb1.1.0.207.0
bootstrap code read in
base = 1d6000, image_start = 0, image_bytes = 99c00
initializing HWRPB at 2000
initializing page table at 1c8000
initializing machine state
setting affinity to the primary CPU
jumping to bootstrap code
%APB-F-MOUNT, failed to mount volume

halted CPU 0

halt code = 5
HALT instruction executed
PC = 20003cc4
warning -- HWRPB is invalid.

>>>sh dev
dka0.0.0.1004.0 DKA0 RZ2CC-KB DC2B
dqa0.0.0.107.0 DQA0 Maxtor 6 E040L0 NAR6
dqa1.1.0.107.0 DQA1 TEAC DV-W58D 1.08
dqb0.0.0.207.0 DQB0 Seagate Technology 1 1.37
dqb1.1.0.207.0 DQB1 ST380011 A 8.11
dva0.0.0.0.1 DVA0
ewa0.0.0.3.0 EWA0 00-00-F8-76-61-8C
pka0.7.0.1004.0 PKA0 SCSI Bus ID 7 5.57
pqa0.0.0.107.0 PQA0 PCI EIDE
pqb0.0.0.207.0 PQB0 PCI EIDE

>>>sh config

Firmware
SRM Console: V6.9-7
ARC Console: 5.67
PALcode: VMS PALcode V1.20-14, OSF PALcode V1.22-17
SROM Version: v5.90

Processor
DECchip (tm) 21164A-2 Pass 433 MHz 96 KBytes SCache
0 MB BCache
PYXIS ASIC Pass 257

MEMORY


Memory Size = 512Mb

Bank Size/Sets Base Addr
------ ---------- ---------
0 512Mb 00000000


BCache Size = 0Mb

Tested Memory = 512Mbytes

PCI Bus
Bus 00 Slot 03: Digital Semiconductor 21143 Network Controller
ewa0.0.0.3.0 00-00-F8-76-61-8C

Bus 00 Slot 07: Cypress PCI Peripheral Controller


Bus 00 Slot 07: PCI IDE

dqa0.0.0.107.0 Maxtor 6 E040L0
dqa1.1.0.107.0 TEAC DV-W58D

Bus 00 Slot 07: PCI IDE

dqb0.0.0.207.0 Seagate Technology 1
dqb1.1.0.207.0 ST380011 A

Bus 00 Slot 07: PCI USB
Bus 00 Slot 20: DECchip 21152 PCI to PCI Bridge
Bus 01 Slot 04: ISP1040 Scsi Controller
pka0.7.0.1004.0 SCSI Bus ID 7
dka0.0.0.1004.0 RZ2CC-KB

Bus 01 Slot 08: Vendor: 10b7 Device: 9200
Bus 01 Slot 10: Digital TGA2 Graphics Controller
ISA
Slot Device Name Type Enabled BaseAddr IRQ DMA
0
0 MOUSE Embedded Yes 60 12
1 KBD Embedded Yes 60 1
2 COM1 Embedded Yes 3f8 4
3 COM2 Embedded Yes 2f8 3
4 LPT1 Embedded Yes 3bc 7
5 FLOPPY Embedded Yes 3f0 6 2
6 EIDE Embedded Yes 1f0 14
3f6 15
170
376
7 ES1888 Embedded Yes 220 5 1
5
8 USB Embedded Yes 10

>>>sh
adv_diag off
auto_action HALT
boot_dev dqb1.1.0.207.0
boot_file
boot_osflags 0,0
boot_reset OFF
bootdef_dev dka0.0.0.1004.0
booted_dev dqb1.1.0.207.0
booted_file
booted_osflags 0,0
char_set 0
console graphics
controlp OFF
d_bell off
d_cleanup on
d_complete off
d_eop off
d_group field
d_harderr halt
d_loghard on
d_logsoft off
d_oper off
d_passes 1
d_quick off
d_report full
d_runtime 0
d_softerr continue
d_startup off
d_status off
d_trace off
dma_prefetch ON
dump_dev
enable_audit ON
ewa0_arp_tries 3
ewa0_bootp_file
ewa0_bootp_server
ewa0_bootp_tries 3
ewa0_def_ginetaddr 0.0.0.0
ewa0_def_inetaddr 0.0.0.0
ewa0_def_inetfile
ewa0_def_sinetaddr 0.0.0.0
ewa0_def_subnetmask 0.0.0.0
ewa0_ginetaddr 0.0.0.0
ewa0_inet_init bootp
ewa0_inetaddr 0.0.0.0
ewa0_inetfile
ewa0_loop_count 3e8
ewa0_loop_inc a
ewa0_loop_patt ffffffff
ewa0_loop_size 2e
ewa0_lp_msg_node 1
ewa0_mode BNC
ewa0_protocols BOOTP
ewa0_sinetaddr 0.0.0.0
ewa0_tftp_tries 3
kbd_hardware_type PCXAL
language 34
language_name Deutsch(Schweiz)
license MU
mopv3_boot OFF
os_type OpenVMS
pal VMS PALcode V1.20-14, OSF PALcode V1.22-17
pci_device_override 0
pci_parity off
pka0_host_id 7
pka0_mode fast
pka0_soft_term on
quick_start OFF
scsi_poll ON
srm2dev
sys_serial_num
tt_allow_login 1
tty_dev 0
version V6.9-7 Oct 30 1998 14:10:45
>>>

Is there any solution booting the installed system?
There is unsupported (?) PCI 3Com NIC in slot 1. FreeBSD 6.2 is able to use it.

TIA,
Author RE: VMS 8.4 install on PW433au with EIDE ports
malmberg
Moderator

Posts: 527
Joined: 15.04.08
Posted on October 19 2017 18:39
On my DS-10, i Seem to remember having to set the IDE devices to use CS (Cable Select) instead of setting them to be master / slave devices.

You might want to try removing the other IDE devices to the bus to see if the boot completes with just the boot device.

If it works, you can start adding IDE devices back one at a time.
Author RE: VMS 8.4 install on PW433au with EIDE ports
rattila
Member

Posts: 56
Location: Budapest
Joined: 11.08.17
Posted on October 19 2017 22:10
Good idea. I'll test it.
So is it possible booting from an IDE disk?
I installed from the same IDE CD to an SCSI disk which is almost working. Almost means: booting, VMS working but TCPIP desn't. :-(
Author RE: VMS 8.4 install on PW433au with EIDE ports
rattila
Member

Posts: 56
Location: Budapest
Joined: 11.08.17
Posted on October 20 2017 02:00
I put the disk into an other PW alone on the IDE bus.
I played with cable connectors (middle or end of cable) and jumpers so the disk was dqa0 and 1 but the result is the same! :-(

The difference is the hardware itself - it seems like a PW433au but no integrated QLogic SCSI controller and maybe the chipset and IDE controller - and the console (SRM) version is: Console V7.2-1 Mar 6 2000 14:47:02
Author RE: VMS 8.4 install on PW433au with EIDE ports
Bruce Claremont
Member

Posts: 606
Joined: 07.01.10
Posted on October 20 2017 02:03
Boot VMS on the CD drive and see if you can manually mount the IDE drive. That will confirm no new hardware issue.

This is the HP 8.4 release, correct? Not the VSi release.
Author RE: VMS 8.4 install on PW433au with EIDE ports
rattila
Member

Posts: 56
Location: Budapest
Joined: 11.08.17
Posted on October 20 2017 02:35
I found this:

"OpenVMS and Personal Workstation ATA (IDE) bootstrap?
OpenVMS will boot and is supported on specific Personal Workstation -au
series platforms, though OpenVMS will require a SCSI CD-ROM if the
Intel Saturn I/O (SIO) IDE chip is present in the configuration— only the
Cypress IDE controller chip is supported by OpenVMS for IDE bootstraps.
(Configurations with the Intel SIO are not generally considered to be
supported systems.)
If you have an -au series system, you can determine which IDE chip you
have using the SRM console command:
SHOW CONFIGURATION
If you see ‘‘Cypress PCI Peripheral Controller’’, you can bootstrap
OpenVMS from IDE storage. If you see ‘‘Intel SIO 82378’’, you will
need to use and bootstrap from SCSI. (A procedure to load DQDRIVER
on the Intel SIO—once the system has bootstrapped from a SCSI device—
is expected to be included as part of the contents of the DQDRIVER
directory on Freeware V5.0 and later.)
Many of the -a series systems will include the Intel SIO, and thus cannot
bootstrap from IDE."

I think I've got an -a (not supported Intel IDE chipset) and an -au (supported Cypress IDE chipset). None of them is able to boot from my IDE disk. :-(
Author RE: VMS 8.4 install on PW433au with EIDE ports
rattila
Member

Posts: 56
Location: Budapest
Joined: 11.08.17
Posted on October 20 2017 02:59
On the same machine I installed from my IDE CD a new OpenVMS v8.4 onto an SCSI disk.
It is working, booting (and bugchecking if I try to start TCPIP).

I mounted the IDE boot disk without problem.

$ sh time
20-OCT-2017 14:44:04
$ sh dev

Device Device Error Volume Free Trans Mnt
Name Status Count Label Blocks Count Cnt
ATEST$DKA0: Online 0
ATEST$DKA200: Mounted 0 ALPHASYS 139294240 324 1
ATEST$DQA0: Mounted alloc 0 ALPHASYS 154638128 1 1
ATEST$DQA1: Offline 1
ATEST$DQB0: Online 0
ATEST$DQB1: Offline 1
ATEST$DVA0: Online 0

As you can see there are 4 disks are connected:
DQA0 - OVMS 8.4 IDE boot disk (Primary master)
DQB0 - other IDE disk (Secondary master)
DKA0 - OVMS 7.11-H2 SCSI ID0
DKA200 - OVMS 8.4 SCSI ID2 - booted from this disk.

I can boot from both SCSI disks but not from IDE.

I used the HP OVMS 8.4 what I downloaded from HP after I got the hobbyist licences. So I think it isn't a VSi release.
I wrote the downloaded ISO to rewritable CD-RW and it was installed from a Teac IDE CD drive. The install was successfull without any error messages and the 1st boot has been unsuccessfull with the mentioned mount fail and HWRB message.

What I did wrong?
The only test could be choosing an other IDE disk, install again OVMS and test it if the original IDE disk was deffected. (But the mount was successfull as you can see.)

$ sh dev/full dqa0

Disk ATEST$DQA0:, device type ST380011A, is online, allocated, deallocate on
dismount, mounted, file-oriented device, shareable, available to cluster,
error logging is enabled.

Error count 0 Operations completed 143
Owner process "SYSTEM" Owner UIC [SYSTEM]
Owner process ID 0000021C Dev Prot S:RWPL,O:RWPL,G:R,W
Reference count 2 Default buffer size 512
Total blocks 156301488 Sectors per track 111
Total cylinders 12573 Tracks per cylinder 112
Logical Volume Size 156301488 Expansion Size Limit 4261348350

Volume label "ALPHASYS" Relative volume number 0
Cluster size 16 Transaction count 1
Free blocks 154638128 Maximum files allowed 16711679
Extend quantity 5 Mount count 1
Mount status Process Cache name "_ATEST$DKA200:XQPCACHE"
Extent cache size 64 Max blocks in extent cache 15463812
File ID cache size 64 Blocks in extent cache 0
Quota cache size 0 Maximum buffers in FCP cache 1750
Volume owner UIC [1,1] Vol Prot S:RWCD,O:RWCD,G:RWCD,W:RWCD

Volume Status: ODS-5, subject to mount verification, file high-water marking,
write-through XFC caching enabled, write-back XQP caching enabled, hard
links enabled, special files enabled.

And here is the SCSI boot disk:

$ sh dev/full dka200

Disk ATEST$DKA200:, device type COMPAQ BD07298572, is online, mounted, file-
oriented device, shareable, available to cluster, error logging is enabled.

Error count 0 Operations completed 5476
Owner process "" Owner UIC [SYSTEM]
Owner process ID 00000000 Dev Prot S:RWPL,O:RWPL,G:R,W
Reference count 174 Default buffer size 512
Current preferred CPU Id 0 Fastpath 1
Total blocks 142264000 Sectors per track 96
Total cylinders 15437 Tracks per cylinder 96
Logical Volume Size 142264000 Expansion Size Limit 4261348350

Volume label "ALPHASYS" Relative volume number 0
Cluster size 16 Transaction count 324
Free blocks 139294240 Maximum files allowed 16711679
Extend quantity 5 Mount count 1
Mount status System Cache name "_ATEST$DKA200:XQPCACHE"
Extent cache size 64 Max blocks in extent cache 13929424
File ID cache size 64 Blocks in extent cache 3168
Quota cache size 0 Maximum buffers in FCP cache 1750
Volume owner UIC [1,1] Vol Prot S:RWCD,O:RWCD,G:RWCD,W:RWCD

Volume Status: ODS-5, subject to mount verification, protected subsystems
enabled, file high-water marking, write-through XFC caching enabled,
write-through XQP caching enabled, hard links enabled, special files
enabled.

TIA,
Author RE: VMS 8.4 install on PW433au with EIDE ports
rattila
Member

Posts: 56
Location: Budapest
Joined: 11.08.17
Posted on October 20 2017 03:10
Is this the solution?

https://groups.google.com/forum/#!msg/comp.os.vms/kWFb-XEN9J0/jkpd48pqd2oJ

My disk is 80GB like in the above example. I try to find a smaller one ...
Author RE: VMS 8.4 install on PW433au with EIDE ports
malmberg
Moderator

Posts: 527
Joined: 15.04.08
Posted on October 20 2017 03:22
The firmware may be a limitation.

IDE disks on OpenVMS are currently limited to 120 GB due to a driver issue.

The driver requires a rewrite to put the drive in an extended IDE mode to access the disk beyond that size.

However, even if you re-write the driver to support the extended mode, there still is another prob.em.

The extended mode requires an EIDE cable and it also requires that the total path length from the IDE controller to the disk is shorter than a specific distance, and since the hardware design of IDE on Alpha was only to support the CD-ROM for installation, it is unknown if it is even possible to meet the cable restrictions and connect a drive.

Also, some models of IDE disks may work and some may not.
Author RE: VMS 8.4 install on PW433au with EIDE ports
rattila
Member

Posts: 56
Location: Budapest
Joined: 11.08.17
Posted on October 20 2017 04:04
The new install into a 4,3GB Seagate disk:

Portion done: 0%...10%...20%

%PCSI-E-CLOSEOUT, error closing DISK$VMS84:[VMS$COMMON.][SYSEXE]MSA$UTIL.EXE;1 a
s output
-SYSTEM-F-DATACHECK, write check error
-SYSTEM-W-NOTSQDEV, not a sequential device
%PCSI-E-OPFAILED, operation failed
Terminating is strongly recommended. Do you want to terminate? [YES]

:-(
Author RE: VMS 8.4 install on PW433au with EIDE ports
rattila
Member

Posts: 56
Location: Budapest
Joined: 11.08.17
Posted on October 21 2017 00:32
I tried to install again on the same disk and it was successfull! :-)

System was able to boot. So there is disk capacity limit for booting.
Jump to Forum:
Login
Username

Password



Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?

Yes

No

You must login to vote.
Shoutbox
You must login to post a message.

gtackett
October 27 2021
Make that DECdfs _2.1A_ for Vax

gtackett
October 27 2021
I'm looking for DECdfs V2.4A kit for VAX. Asking here just in case anyone is still listening.

MarkRLV
September 17 2021
At one time, didn't this web site have a job board? I would love to use my legacy skills one last time in my career.

malmberg
January 18 2021
New Hobbyist PAKs for VAX/VMS are no longer available according to reports. Only commercial licenses are reported to be for sale from HPE

dfilip
January 16 2021
Can someone please point me to hobbyist license pak? I'm looking for VAX/VMS 7.1, DECnet Phase IV, and UCX/TCPIP ... have the 7.1 media, need the license paks ... thanks!

Bart
October 16 2020
OpenVMS, and this website!

malmberg
September 05 2020
VSI community non-commercial licenses for AXP/IA64 are available now.

malmberg
September 05 2020
See the forum about licensing. Don't know if HPE hobby licenses still being issued. Commercial licenses still being sold.

silfox70
September 01 2020
I need the license for OpenVMS7.3. Where can I find them?

malmberg
August 29 2020
Eisner, which is currently being moved, got an SSH update and the keys were updated to more modern encryption standards.

jiml
July 11 2020
ssh to eisner is now giving (on linux) "WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!" , Has the server key in fact changed ? Of WHO can we ask that somewhere on the eisner webpage they

wyan
May 06 2020
Turns out I had an account here, it still was set to my location a decade ago, so hey, I'm back after over a decade!

Hein
April 21 2020
Hi all, haven't been here in years. Good to see it is all there still. I'm looking around at the forum to stop/start msipcap - 'could not be stopped' - for now. I'll shutdown FreeA

EstesDave
January 09 2020
does anyone have or know of DRB32 manuals

romaxmaniax
November 04 2019
V6.1

Shoutbox Archive