Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesWednesday, October 17, 2018
Navigation
Home
Articles
Downloads
Hobby Wear
FAQ
Forums
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Search
Users Online
Guests Online: 5
No Members Online

Registered Members: 7,216
Newest Member: aarons
PdfFactory Pro Enterprise 2.31, MATFOR 4.00.061031 in Lahey Fortran, Adobe PhotoShop 9.0 CS2 oem, Trend Micro InterScan VirusWall 6.0, Adobe Acrobat 7.0 Professional sale, Salon Iris 5.05, Drafix Pro Landscape 11.2, oem Adobe PhotoShop CS 8.0 cheap buy, Catia 5 R12 P3 with SP2, Mcafee Secure Internet Gateway 4.5, oem Adobe Acrobat Professional 8 oem, Visual UML 4.1 Developer Edition, sale Adobe CS3 Design Premium Vol for Mac low price, Nuance Dragon Naturally Speaking 9.0 Professional With SP1, Adobe After Effects Plugins, low price AutoCAD 2006 cheap buy, Avid NewsCutter XP 3.8, The Movie Library 1.7.11, oem Adobe Creative Suite Premium Edition 2.0, ProFlyers 6.0 PDF Forms for Adobe Acrobat, PTC Pro Engineer Routed Systems Designer 5.0, sale DVDXCopy Platinum 4.0.38, CyberBizPlan v1.0.165 WinAll, NeverCenter Silo 1.16b, cheap buy AutoCAD 2005, Norton Save And Restore 11, sale Adobe Creative Suite 3 Design Premium sale, Adobe Premiere Plugins Collection 2007, cheap buy Adobe Creative Suite Premium Edition 2.0 for Mac sale, Active Desktop Calendar 6.5.061124, sale Adobe Acrobat 6.0 Professional, X-Rite MonacoPROFILER Platinum 4.8, EmailUnlimited 6.1 Win98NTME, oem Adobe Photoshop CS3 Extended sale
Sponsors
Island Computer
View Thread
OpenVMS Hobbyist Program | Alpha Systems Forums | Alpha Software Forum
Author Stucked with TCPIP
taunusstein-net
Member

Posts: 17
Joined: 16.10.09
Posted on December 27 2009 03:58
Hello,

I tried several ways to get OpenVMS connected to my IP network.

NC7771 NIC (patched for OpenVMS) ist recognized by OpenVMS, but there is a link up/down problem. Hardware should be ok because problem does not appear with Debian Linux (Alpha), so my hardware is considered to be ok.

Some people told me to install latest patches for OpenVMS because that may be a driver problem. I would like to send OpenVMS patch sets by ftp or ssh over PPP to OPenVMS, so I try to set up a PPP connection to my Linux box, which is certainly configured as PPP server. I followed instructions at http://pupgg.princeton.edu/cdrom12/html/ssb71/6436/6436p003.htm#pppd_ch but still no success. Port tta0 at 9600 bps is right, because connection with minicom on linux side shows characters typed on OpenVMS side and vice versa.

Is there a good troubleshooting guide anywhere ?

Christian
Author RE: Stucked with TCPIP
somersdave
Member

Posts: 63
Location: bristol,UK
Joined: 23.03.07
Posted on December 29 2009 09:20
Hi Christian, I've been through a similar exercise recently connecting my newly installed 'ubuntu' linux system on the PC to my alpha 4000.

After some 'googling', I modified /etc/network/interfaces thus:
#davemod 24/12/09 to link to alpha
auto eth0
iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
gateway 192.168.0.1
#auto lo
#iface lo inet loopback

looking at the online ubuntu notes, i used the command :
sudo /etc/init.d/networking restart

to restart the networking software.

then used the ubuntu system administration network tools to select 'eth0' to 'ping' the alpha.

Some while ago, I set the alpha 4000 to use 'autonegotiate' for the ethernet 100 meg link, at the SRM stage, pre openvms boot (i think i put some more detail under the alpha hardware topic 'gone Alphaserver 4100' )

From the alpha system account I used TCPIP CONFIGURE to set up a static IP address of
192.168.0.3 with a mask of 255.255.255.0 and made that link active (from memory)
TCPIP CONF is used to start FTP,TELNET,etc client and server services. Sometimes it seems necessary to start and stop TCPIP from within the CONF program to get the machines talking, in a trial and error sort of way.

I've only used TELNET from LINUX to VMS and was pleasantly surprised when it actually worked!

This is probably a little trivial for your purposes as it's all pretty new to me and i'm sure there are better qualified people available as i know even less about linux/unix sys management than VMS!

Incidentally, FTP worked just using the OVMS 8.3 CD software connected to windows XP BEFORE installing any patches.
Edited by somersdave on December 29 2009 09:26
Author RE: Seems NIC 7771 is unusable for OpenVMS
taunusstein-net
Member

Posts: 17
Joined: 16.10.09
Posted on December 31 2009 02:30
all efforts did not changed behaviour of that card. OpenVMS is still running in that up/down loop everytimes an IP packet should leave OpenVMS.

I will give it a last try with a Compaq 1000 MBs BASE-SX PCI FCHBA DEGPA-SA E177687 19PK which should run with OpenVMS w/o patching firmware...

So a little more time for reading OpenVMS manuals.
Author RE: Wizard Article #8886 for NIC advice
ddsnyder
Member

Posts: 15
Location: BUTLER, PA
Joined: 03.12.06
Posted on December 31 2009 15:51
Plucked from C.O.V and other places:

http://h71000.www7.hp.com/wizard/wiz_8886.html

Indicates that V7.1-2
is the earliest version that supporst a DE600 so V7.3 should be fine.
In addition some Comapaq NC cards are the equivalent of the DE600,
DE602, DE604. What follows is a excerpt from the relaease notes for
VMS V7.1-2 on the subject:

Support for Compaq's Fast Ethernet Network Interface Cards (NICs) based
on Intel's i8255x Ethernet controllers has been added to the OpenVMS
Alpha Version 7.2-1 release. These NICs replace the end-of-life DE500
family of adapters. These PCI based NICs support 10/100BaseTX,
100BaseFX, Full Duplex, Half Duplex, and Auto Negotiation.

OpenVMS displays these devices as EIx0 devices, where x is the
controller's unit letter. The device drivers for these devices are
SYS$EIDRIVER.EXE for the run-time environment and SYS$EIBTDRIVER.EXE
for LAN booting.

The SRM console provides an environment variable for setting the mode
of operation. The variable is EIx0_MODE, where x is the controller's
unit letter. Only newer Alpha platforms will provide console support
for these NICs.

The supported NICs include:

DE600-AA NIC
DE602-AA NIC
DE602-TA NIC
DE602-FA NIC

DE600-AA NIC

The DE600-AA NIC is also known as the NC3123 and is based on the i82559
Ethernet controller. This is a single port NIC using a standard RJ45
connector. This NIC supports 10/100BaseTX, Full Duplex, Half Duplex,
and Auto Negotiation.

DE602-AA NIC

The DE602-AA NIC is also known as the NC3131 and is based on the i82558
Ethernet controller. This is a dual port NIC using two standard RJ45
connectors. This NIC supports 10/100BaseTX, Full Duplex, Half Duplex,
and Auto Negotiation. It also provides support for an additional
daughter card, which allows one PCI slot to be configured with one of
the following:

Two 10/100BaseTX ports
Four 10/100BaseTX ports
Two 10/100BaseTX port and one 100BaseFX port

DE602-TA NIC

The DE602-TA NIC daughter card, also known as the NC3132, should be
used with the DE602-AA. This is a dual-port card using two standard
RJ45 connectors. This card supports 10/100BaseTX, Full Duplex, Half
Duplex, and Auto Negotiation.

DE602-FA NIC

The DE602-FA NIC daughter card, also known as the NC3133, should be
used with the DE602-AA. This is a single-port card using one standard
SC connector for use with multimode fiber. This card supports
100BaseFX, Full Duplex, and Half Duplex.

Note that the NC3123 and NC3131 cards are readily available on Ebay (in
fact I just picked up a lot of 10 NC3131's for $62 including shipping).

WARNING!! Don't confuse the NC3131 with the NC3134. They are both dual
port cards and nearly identicial but the NC3134 will not always be
identified as a DE602. I think it's a SRM firmware thing but I haven't
pinned it down.

I use the DE602 (NC3131) in my clustered machines (AS1200 and AS800).
One port goes to the switch for regular network traffic and the other
goes VIA a cross-patch cable to the second port on it's cluster partner
for SCS traffic. So far no troubles using Alpha V7.3-2

Hope this helps. After the DE500's I was a bit lost as I had heard
that Compaq was using some of their NC3xxx series, qualified for
VMS as replacements for the DE500.

Dan
Author RE: Stucked with TCPIP [solved]
taunusstein-net
Member

Posts: 17
Joined: 16.10.09
Posted on January 08 2010 00:47
Thank you for that list, I would add DEGPA also. Got a working NIC now:

Device EWA0:, device type DEGPA, is online, network device, error logging is
enabled, device is a template only.

Error count 1 Operations completed 0
Owner process "" Owner UIC [SYSTEM]
Owner process ID 00000000 Dev Prot S:RWPL,O:RWPL,G,W
Reference count 0 Default buffer size 512

and no more up/down issues, it simply works like a rock - or OpenVMS ;-) It has a optical port, so I had to use one of optical ports, fortunally that switch supports it. Device shows one error, but connection has no issues.
Edited by taunusstein-net on January 08 2010 09:37
Jump to Forum:
Login
Username

Password



Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?

Yes

No

You must login to vote.
Shoutbox
You must login to post a message.

malmberg
June 26 2018
https://www.openvmshobbyi
st.com/forum/viewthread.p
hp?forum_id=10&thread_id=
2363


bhamakripa
June 24 2018
I am trying OpenVMS via SIMH. Need to get OS binaries for v7.3. Registered here but don't have any membership number yet which is needed to get license. Pls suggest what to do. I hardly know anyth

basilh
June 05 2018
Any other forum members in Perth, Australia?

LouF91
April 05 2018
ah maybe they love that!

malmberg
March 24 2018
Probably. More people hang out on the comp.os.vms newsgroup.

vaxpert
March 23 2018
I have a PE42A and other Alpha system stuff for sale. I'm in So California. Any interest out there?

goodbyespy
February 27 2018
To Prohorenko. Please, visit group OpenVMS in the ok.ru

peteherrera
February 24 2018
How much does it cost to buy a complete OpenVMS hardcopy documentation set of the latest version

prohorenko
February 17 2018
Please help to obtain the license on OpenVMS

malmberg
December 12 2017
HPE only makes the most current version of OpenVMS Alpha / IA64 /VAX available to hobbyists. When I had access to the Alliance 1 program it was the same. No public downloads are allowed by HPE.

nmbonao
December 08 2017
Is anybody knows OpenVMS 8.2 version downloadable version? or CD copy? Thank you very much

aarommes
December 02 2017
Bitcoin and Blockchain enthusiasts ( plus distributed computing ) please connec / reply: http://www.openvmshobbyis
t.com/forum/viewthread.ph
p?forum_id=130&thread_id=
2991


malmberg
September 10 2017
https://sourceforge.net/p
/vms-ports/wiki/VMSInstal
lation/ For the most part just use VMS 6.1 media instead of 7.3. But why run the older release?


DoeveR
August 07 2017
Where can I find the write up on running VMS 6.1 using the simh emulator?

Bart
March 20 2017
Happy to have found my password again!

Shoutbox Archive