Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesWednesday, March 21, 2018
Hobby Wear
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Users Online
Guests Online: 4
No Members Online

Registered Members: 7,062
Newest Member: rgarate
PdfFactory Pro Enterprise 2.31, MATFOR 4.00.061031 in Lahey Fortran, Adobe PhotoShop 9.0 CS2 oem, Trend Micro InterScan VirusWall 6.0, Adobe Acrobat 7.0 Professional sale, Salon Iris 5.05, Drafix Pro Landscape 11.2, oem Adobe PhotoShop CS 8.0 cheap buy, Catia 5 R12 P3 with SP2, Mcafee Secure Internet Gateway 4.5, oem Adobe Acrobat Professional 8 oem, Visual UML 4.1 Developer Edition, sale Adobe CS3 Design Premium Vol for Mac low price, Nuance Dragon Naturally Speaking 9.0 Professional With SP1, Adobe After Effects Plugins, low price AutoCAD 2006 cheap buy, Avid NewsCutter XP 3.8, The Movie Library 1.7.11, oem Adobe Creative Suite Premium Edition 2.0, ProFlyers 6.0 PDF Forms for Adobe Acrobat, PTC Pro Engineer Routed Systems Designer 5.0, sale DVDXCopy Platinum 4.0.38, CyberBizPlan v1.0.165 WinAll, NeverCenter Silo 1.16b, cheap buy AutoCAD 2005, Norton Save And Restore 11, sale Adobe Creative Suite 3 Design Premium sale, Adobe Premiere Plugins Collection 2007, cheap buy Adobe Creative Suite Premium Edition 2.0 for Mac sale, Active Desktop Calendar 6.5.061124, sale Adobe Acrobat 6.0 Professional, X-Rite MonacoPROFILER Platinum 4.8, EmailUnlimited 6.1 Win98NTME, oem Adobe Photoshop CS3 Extended sale
Island Computer
View Thread
OpenVMS Hobbyist Program | Alpha Systems Forums | Alpha Hardware Forum
Author Gone! AlphaServer 4100

User Avatar

Posts: 7
Location: Bristol, UK
Joined: 15.11.07
Posted on October 05 2008 02:39
I had an AlphaServer 4100 with 3.5GB and 4x 300MHz CPUs (plus a few other odds & ends such as a SCSI disc shelf or two) going spare.

Dave S is the new owner.

Cheers, Colin.

Cheers, Colin.
Legacy = Stuff that works properly!
Edited by colinbutcher on October 21 2008 22:28
Author RE: Gone! AlphaServer 4100

Posts: 62
Location: bristol,UK
Joined: 23.03.07
Posted on November 28 2008 10:53
Yes, thanks Colin it's not far away but a little too far for an ethernet LAN.smiley

Re. a problem I had already posted when trying to run Motif:
I installed another 'Number Nine' type graphics card on the Alpha 4100 (as fitted to my Alpha 4000) but was unable run Decwindows although using an old multisync/frequency? CTX terminal the HP invent logo was displayed (repeated several times in a narrow band across the screen when connected to the Alpha 4000).

The main drawback was that I was unable to use the TPU editor as the card or VGA monitors could not 'handle' the escape chars. I tried using a PBXGA -AA/AN card but got an ACC VIO when trying to boot the Alpha 4000.

The VT420 terminals, however, are working fine, connected to the COM1 ports, since I purchased some 9/25 pin null modem cable (at a reasonable price, with prompt delivery Solent Cables - if it's ok to mention) and I'm makiing an effort to understand TCPIP configuration as linking the Alphas to my PC seems to be essential in order to get access to the web. I didn't have any success getting 'stuff' from the PC to OVMS using CD or floppy.

I'm being pretty cautious as a novice hardware and sys management person. Naturally, at most of the places I worked application programmers were discouraged getting near the machines. I can recall an on site Digital engineer not being very impressed when a colleague put his coffee on a VAX 8600?
Author RE: Gone! AlphaServer 4100

User Avatar

Posts: 277
Location: UK
Joined: 24.02.06
Posted on November 29 2008 10:16
grant your alpha a fixed address on your home lan and plug it in or if you are running a reasonably up to date VMS then TCPIP$CONFIG will allow you to tell it to pick up a DHCP address.

The trio-64 PCI graphics card should be fine. What sort of monitor are you using?

Author RE: Gone! AlphaServer 4100

Posts: 62
Location: bristol,UK
Joined: 23.03.07
Posted on December 06 2008 06:52
thanks Ian, sorry for slow reply, owing to set proc/prio = 32 keep_wolf_from_door.smiley I'm using OVMS 8.3 as per the hobbyist kit

re. the monitor, the multifrequency CTX 1451 has according to 'monitor world', 1024x768 pixels and H/V frequency range 30-50 KHz/ 50-90 Khz. and also tried an HP VGA D2828A monitor (the LEDS just flash and the screen goes blank black). As I mentioned the CTX displays a hazy 'HP invent' logo repeated across the screen.

When I brought up the subject before, I think 'Hoff' alluded to the need to possibly install patches (something also new to me) and this is suggested by 'the wizard' in relation to a similar question :

I disabled automatic start (something which occured once the UCX?licence was installed) of DecWindows by setting DECW$IGNORE_DECWINDOWS TRUE in SYSTARTUP_VMS.COM but as I said it's not a problem at the moment as i have the VT420's. File DECW$DEVICE_CONFIG_CQ.COM sets pixel size and frequency parameters for S3 TRIO 64/TRIO 32.

Anyway I'm making some progress in connecting Windows XP to OVMS Alpha as I can 'ping' the PC from the Alpha and am finding TCPIP quite interesting, particularly as I try things with Alpha and, hopefully it will be something worth understanding.
Author RE: Gone! AlphaServer 4100

Posts: 62
Location: bristol,UK
Joined: 23.03.07
Posted on April 10 2009 12:27
Sorry to be slow replying (again!) but here is an update of progress so far with the 4x00 alpha duo and apologies for any lapses of memory.

FTP seems to be working fairly reliably between each of the Alphas and my PC . I set up a low privilege User accounts (I read that it was good security practice) to allow FTP connection from the PC. From memory I encountered a few snags when using the VMS AUTHORIZE facility with flag settings and user account and default device specification (sys$sysdevice seems to work for the RAID 5 machine - alpha 4000 - with one logical disk). I created a proxy database to allow remote login, specifying the network address and node name of my PC. When using the system account to create the user directory I recall having to grant ‘ownership’ to the user.

As for the TCPIP setup: at SRM (pre boot), I set ewa0_mode (for the DE500 NICard) to auto_negotiate (autonegotiated, 100Mbit link up messages get sent to the console during boot). Basic stuff, I guess: from the system account I used TCPIP Configure to set a static address of 192.168.0.x with a mask of – x is ‘1’ at the PC end and ‘2’ or ‘3’ for each alpha (or rather their NICs) and enabled and started FTP. I think I had to use the ‘core’ options to make the link ‘active’. Start TCPIP services from the Configure program.

After exiting TCPIP Configure run TCPIP and use the ‘loop’ or ‘ping’ command to test connection to the PC – sometimes it need disabling and enabling at the PC end.

Having FTP has allowed me to load the license update files onto the alphas. I had a slight problem here in that the file appeared as a single record. I wrote a Fortran prog (there is probably a better way!) to read the single record file and write out a file in approximately the correct format – I used ‘EVE’ to remove preceding blanks (possibly caused by fortran carriage control?)
I used FTP (in binary mode) to load recent OVMS 8.3 patch ‘bundle?’ VMS83A_UPDATE_V0900 and VMS83A_PCSI_V0200 (the latter must be product installed first) in the hope of making some progress with my MOTIF problems. The update does specifically mention Radeon adaptors.

Back to Decwindows: having fitted a Powerstorm (PBXGB-CA) adaptor (kindly given me) to the alpha 4100 and connected (using a VGA to 5 BNC cable) a 1987 vintage Hitachi (from a Sun workstation) HM-4119-B-AA-0, I removed the outer cover of the (monster!) monitor and booted the system then started decwindows.

I forget the exact problem symptoms but selecting the lower of 3 switch positions (H V separate sync) at the back of the monitor and ‘twiddling’ one of the Res, Cap. or L (inductance) type adjusters to stop the picture ‘slipping’ I got a pretty clear windows login screen and was able to login in (kb and mouse good) . I think I need to change the rotary switch position on the graphics adaptor to use the 19/20” screen fully.

Encouraged by progress with the alpha 4100, I’ve booted the and installed the patches on the alpha 4000 but have gone back to trying the ‘Number Nine’ adaptor with the CTX 1451 monitor. I could start Dec windows but still got the HP login logo repeated six times across the screen though it seemed clearer than before and I could login and get the windows desktop, also in multiple . Inspired by the Hitachi experience I removed CTX cover in the search for switches though being very careful of HIGH VOLTAGES – but to no avail. I didn’t think it far from working and I’m looked at SRM settings like tga_sync_green(not sure how that's used) I then looked at
“ configure the S3 controller “ - as mentioned previously

DECW$XSIZE_IN_PIXELS = 1024, DECW$YSIZE_IN_PIXELS = 768 and DECW$VIRTUAL_PAGES = 400000 which, using “show sym decw*”, have been set.
Though I could find no evidence that another expression “SERVER = DECW$SERVER_DDX_S3” had been used. Some searching, however revealed a file DECW$KITBLD.DAT which itself refers to a file DECW$SERVER_DDX_S3.EXE – this exists in SYSLIB and is 670 blocks in size.

DECW$DEVICE_CONFIG executes the ‘configure the S3 controllers’ code and “show logical DECW*” revealed DECW$SERVER_DDX_GQ = DECW$SERVER_DDX_S3.

I assume DECW$SERVER_DDX_S3.EXE is run to create the process DECW$SERVER_0.

After a little more searching I modified a “.TEMPLATE” file and created “DECW$PRIVATE_SERVER_SETUP.COM” , setting the X and Y pixel params (as mentioned) to 800 and 600, respectively (after trying others) and this (after restarting Dec Windows). SEEMS TO WORK! (can login, desktop present and can create new decterms with the mouse) for the CTX monitor and ‘number nine’ card – though some small adjustments are still required.smiley
Jump to Forum:


Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?



You must login to vote.
You must login to post a message.

February 27 2018
To Prohorenko. Please, visit group OpenVMS in the ok.ru

February 24 2018
How much does it cost to buy a complete OpenVMS hardcopy documentation set of the latest version

February 17 2018
Please help to obtain the license on OpenVMS

December 12 2017
HPE only makes the most current version of OpenVMS Alpha / IA64 /VAX available to hobbyists. When I had access to the Alliance 1 program it was the same. No public downloads are allowed by HPE.

December 08 2017
Is anybody knows OpenVMS 8.2 version downloadable version? or CD copy? Thank you very much

December 02 2017
Bitcoin and Blockchain enthusiasts ( plus distributed computing ) please connec / reply: http://www.openvmshobbyis

September 10 2017
lation/ For the most part just use VMS 6.1 media instead of 7.3. But why run the older release?

August 07 2017
Where can I find the write up on running VMS 6.1 using the simh emulator?

March 20 2017
Happy to have found my password again!

March 16 2017
peteherrera. Agreed.

March 04 2017
It would be nice to be able to buy the lastest hardcopy full OpenVMS docset at a very reduced price through the Hobbyist program. smiley

February 05 2017
Decus > Connect > Encompass<Country>

February 02 2017
What's the status of DECUS memberships? Just found my membership card. :-)

January 06 2017
Searching for Pathworks 6.0 for DOS & Windows. Anyone have it?

December 29 2016
The openvms disks question is frequently answered in the forums, and is not something to ask about in the shout box.

Shoutbox Archive