Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesSunday, February 05, 2023
Navigation
Home
Articles
Downloads
Hobby Wear
FAQ
Forums
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Search
Users Online
Guests Online: 11
No Members Online

Registered Members: 7,681
Newest Member: MrManul
Sponsors
Island Computer
View Thread
OpenVMS Hobbyist Program | Hobbyists and OpenVMS | How I Use OpenVMS
Author arragh - unable to run games.
marla
Member

Posts: 11
Location: Australia
Joined: 26.02.10
Posted on April 03 2010 15:11
Hello everyone,

I have a few questions about running the games which are found under the game downloads. I am very new to OpenVMS, having had my emulator running for a week now (Yay).

A/
My operating system is debian linux & I have the simh/vax running openvms. I have downloaded the various games here and tried to get them to run with no success.

To take one game as an example, I have,
1/ downloaded the 'dungeon.zip' to the linux.
2/ run under linux, 'unzip -a dungeon.zip' to get a file 'dungeon.bck' (I'm not sure if the -a option was needed but I read somewhere that it was)
3/ placed this in a directory calling it 'GAMES' and made a small .iso file
4/ mounted this .iso file in the openvms simulation.
5/ and copied the dungeon.bck into a user directory (on openvms).

At this point I dont really know what I am doing. The 'BACKUP' command shows the following:

$ BACKUP/LIST DUNGEON.BCK/SAVE
Listing of save set(s)
%BACKUP-F-NOTSAVESET, DUA1:[ROOT.GAMES]DUNGEON.BCK;1 is not a BACKUP save set
$

My question is what am I doing wrong ? What else do I have to do ?

B/
I have tried a few times to download the 'Battlestar' game, but it does not download. I likes this one and it would be great to get the openvms to run it. It has such a dramatic begining.

..... The floor shudders and the sounds of dull explosions rumble though the room. From a window in the wall ahead comes a view of darkest space. ..... r ..... These are the executive suites of the battlestar. Luxurious staterooms carpeted with crushed velvet and adorned with beaten gold open onto this parlor. .....

Any assistance would be much appreciated.
Peter.
Edited by marla on April 03 2010 20:26
Author RE: arragh - unable to run games.
matt002
Member

Posts: 12
Joined: 31.03.10
Posted on April 04 2010 01:03
Backup savesets use a number of 'extended' filesystem attributes to store their record size, file format etc... When you copy a backup saveset to a non-OpenVMS filesystem (e.g. ext3, ntfs), these attributes are lost because these filesystems do not have the necessary fields to stores this information.

If you unzip the file on the VMS system (using InfoZip), the saveset will probably be created with the correct RMS attributes because the zip file will (likely) have been created to store these.

The other option (and probably the quickest in this case) is the use the 'fix saveset' command file available on the HP website:

http://h71000.www7.hp.com/openvms/freeware/backup.html

Matt
http://www.9track.net/
Author RE: arragh - unable to run games.
marla
Member

Posts: 11
Location: Australia
Joined: 26.02.10
Posted on April 06 2010 00:42
Heya matt002,

Some excellent information, thanks for the posting. Im still not there yet and I dont have it working yet, but hey, Im having fun : )

Thanks again,
Peter
Edited by marla on April 06 2010 00:43
Author RE: arragh - unable to run games.
muddflapp
Member

Posts: 17
Location: Texas
Joined: 01.06.21
Posted on June 05 2021 14:07
OpenVMS Backup Save Sets become "corrupted" during FTP copies. In binary mode it sets the MRS and LRS attributes to 512 bytes which is illegal for Backup Save Sets.
This script reads the first record (in 512 byte format) and looks at byte 28. That is the original blocksize that the backup saveset was created with. Look at this script

$! Fix_Backup_Saveset_Attributes -- Fix Backup save sets sds 15-may-2010
$!___________________________________________________________________________
$!
$! When Backup Save Sets go through an FTP transfer, typically the record
$! attributes get mangled to be a maximum record size of 512 and the
$! logical record length of 512.
$!
$! When Backup Save Sets get created, the range of allowable record lengths
$! range from 2048-65535. The BACKUP command has a /BLOCK qualifier that
$! specifies this value. The default is 8192 for distination tape drives, and
$! 32256 for destination disk files.
$!____________________________________________________________________________
$ Gosub Setup
$ previous_file = current_file
$ loop: current_file = f$search(P1)
$
$ If current_file .eqs. previous_file .or. current_file .eqs. "" then exit
$ previous_file = current_file
$ old_mrs = f$file(current_file,"MRS"smiley
$ old_lrl = f$file(current_file,"LRL"smiley
$ old_rat = f$file(current_file,"RAT"smiley
$ old_org = f$file(current_file,"ORG"smiley
$ if f$file(current_file,"SHELVED"smiley
$ then
$ say f$fao("!23AS !AS","Skipping shelved file:", current_file)
$ goto loop
$ endif
$ set file/attrib=(ORG=SEQ,RAT=none,MRS=512,LRL=512) 'current_file'
$
$ open/read/share/error=put_it_back file 'current_file'
$ read/nolock/error=eof file rec
$ close/error=put_it_back file
$
$ bbh_l_blocksize = %x28*8
$ BlockSize = f$cvui(bbh_l_blocksize,32,rec)
$
$ Say f$fao("mrs:!5UW,lrl:!5UW old !AS", old_mrs,old_lrl,current_file)
$ set file/attrib=(MRS='BlockSize',LRL='BlockSize'smiley 'current_file'
$
$ new_mrs = f$file(current_file,"MRS"smiley
$ new_lrl = f$file(current_file,"LRL"smiley
$ say f$fao("mrs:!5UW,lrl:!5UW new !AS", new_mrs,new_lrl,current_file)
$ goto loop
$
$ eof: close file
$ put_it_back:
$ set file/attrib=-
(ORG:'old_seq',RAT:'old_rat',MRS:'old_mrs',LRL:'old_lrl'smiley -
'current_file'
$ goto loop
$
$ Setup:
$ pgm = f$parse(f$environment("procedure"smiley,,,"name"smiley
$ quiet = %x10000000
$ on control_Y then interrupt\'pgm'
$ on warning then exit $status .or. quiet
$ say := Write Sys$output
$ current_file :=
$ return
Jump to Forum:
Login
Username

Password



Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?

Yes

No

You must login to vote.
Shoutbox
You must login to post a message.

malmberg
August 04 2022
No more VAX hobbyist licenses. Community licenses for Alpha/IA64/X86_64 VMS Software Inc. Commercial VMS software licenses for VAX available from HPE.

ozboomer
July 20 2022
Just re-visiting.. No more hobbyist licenses? Is that from vmssoftware.com, no 'community' licenses?

valdirfranco
July 01 2022
No more hobbyist license...sad

mister_wavey
February 12 2022
I recall that the disks failed on the public access VMS systems that included Fafner

parwezw
January 03 2022
Anyone know what happened to FAFNER.DYNDS.ORG? I had a hobbyist account here but can longer access the site.

gtackett
October 27 2021
Make that DECdfs _2.1A_ for Vax

gtackett
October 27 2021
I'm looking for DECdfs V2.4A kit for VAX. Asking here just in case anyone is still listening.

MarkRLV
September 17 2021
At one time, didn't this web site have a job board? I would love to use my legacy skills one last time in my career.

malmberg
January 18 2021
New Hobbyist PAKs for VAX/VMS are no longer available according to reports. Only commercial licenses are reported to be for sale from HPE

dfilip
January 16 2021
Can someone please point me to hobbyist license pak? I'm looking for VAX/VMS 7.1, DECnet Phase IV, and UCX/TCPIP ... have the 7.1 media, need the license paks ... thanks!

Bart
October 16 2020
OpenVMS, and this website!

malmberg
September 05 2020
VSI community non-commercial licenses for AXP/IA64 are available now.

malmberg
September 05 2020
See the forum about licensing. Don't know if HPE hobby licenses still being issued. Commercial licenses still being sold.

silfox70
September 01 2020
I need the license for OpenVMS7.3. Where can I find them?

malmberg
August 29 2020
Eisner, which is currently being moved, got an SSH update and the keys were updated to more modern encryption standards.

Shoutbox Archive