Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesThursday, June 13, 2024
Hobby Wear
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Users Online
Guests Online: 7
No Members Online

Registered Members: 7,708
Newest Member: nifseg
Island Computer
View Thread
OpenVMS Hobbyist Program | OpenVMS Hobbyist Media Kits | OpenVMS Alpha Media Kits
Author Problem with restoring the backup save sets when installing

Posts: 28
Location: Sofia, Bulgaria
Joined: 02.01.06
Posted on February 25 2007 09:48
Up to the moment I've always used FTP to download from another home server the software kits, then with the RESET_BACKUP_SAVESET_FILE_ATTRIBUTES.COM procedure found on the HP freeware site I restored the atrributes and the installation was successfull.
Today I created CDs with the products (the same files from the FTP server - they are OK), and when I start the installation of a product I get:
%VMSINSTAL-I-RESTORE, Restoring product save set A ...
%BACKUP-F-NOTSAVESET, DKA400:[CC065.KIT]CC065.A;1 is not a BACKUP save set
%VMSINSTAL-E-NOSAVESET, Save set A cannot be restored.

What can be the cause? The CDWRITER is a modern ATA drive on GNU/Linux box. I have as well an old YAMAHA SCSI Writer - in case the problem is 512/2048 block size related (in fact I do not know what block size uses that YAMAHA - I just hope is 512). I could connect it to the OpenVMS but how I can transfer all the files to write them from OVMS (besides that I do not have enough space)? If I use FTP I'll have to restore the attributes with the above mentioned procedure on all the files... it is a tedious task - I have to find a big hard drive, then transfer, then repair the save sets...
Is there a way to write the kits from a PC?

P.S. the CDROM on OVMS that I use for read/install the products is OK - I installed OVMS it self from it.

P.P.S. I checked - the YAMAHA writer has jumper for the block size. Will it write correctly the CDs? Of course I'll try tomorrow with it, but maybe occasionally somebody has tried this already, or knows what the problem is.
109218396 http://azonmedia.com

Posts: 11
Location: Leon, Spain
Joined: 28.03.06
Posted on February 26 2007 08:43
I was having similar problems, with files downloaded from FTP and burning them on CD and such... I finally found the solution in some webpage:


should repair the block sizes of the files (they have to be on hard disk, though, otherwise this will fail). Change the LRL parameter accordingly: IIRC CC064 needs it to be 09216, as well as a some other packages too...

Hope this helps!

Author decset problem

Posts: 9
Joined: 02.02.07
Posted on March 02 2007 10:18
hey there,

I used the command that you provided, to the glory of many now installed kits. Now however, i'm facing a strange problem. In the same way i restored the other kits after copying to my harddisk (the previous quoted SET FILE/ATTRIBUTES...LRL:09216... command), i restored the 11 save sets. Installation goes well, till it starts to restore save set c. here are some errors, the real list is much longer, but constitutes of the same errors.

%VMSINSTAL-I-RESTORE, Restoring product save set C ...
%BACKUP-E-READERR, error reading DKA0:[WARD.FTPFILES]decset124.c;3
-BACKUP-E-BLOCKCRC, software block CRC error
%BACKUP-E-INVBLKSIZE, invalid block size in save set
%BACKUP-E-INVRECSIZ, invalid record size in save set
%BACKUP-E-INVRECSIZ, invalid record size in save set
%BACKUP-E-BLOCKLOST, block of DKA0:[WARD.FTPFILES]decset124.c;3 lost due to unrecoverable error
-BACKUP-E-HDRCRC, software header CRC error
%BACKUP-E-READERR, error reading DKA0:[WARD.FTPFILES]decset124.c;3
-BACKUP-E-HDRCRC, software header CRC error
%BACKUP-E-INVBLKSIZE, invalid block size in save set

i re-downloaded the file, same problem. I puzzles me, because the rest (.c files in other kits, and .a and .b file in this kit)worked fine.

Any ideas?

thanks in advance....
Super Administrator

User Avatar

Posts: 126
Location: Plano, TX
Joined: 20.02.08
Posted on March 02 2007 16:51
Do a BACKUP/LIST DECSET124.C/SAVE and look at the results. It will include displaying the header, which includes the actual blocksize. Now, typically SPKITBLD.COM (The command procedure commonly used to build VMSINSTAL kits) will set the blocksize to a nice value, but this is always a good doublecheck, since they may not have used SPKITBLD.
Author how to set the blocksize

Posts: 9
Joined: 02.02.07
Posted on March 04 2007 01:16
thanks. Sorry for all the stupid questions smiley
Jump to Forum:


Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?



You must login to vote.
You must login to post a message.

August 04 2022
No more VAX hobbyist licenses. Community licenses for Alpha/IA64/X86_64 VMS Software Inc. Commercial VMS software licenses for VAX available from HPE.

July 20 2022
Just re-visiting.. No more hobbyist licenses? Is that from vmssoftware.com, no 'community' licenses?

July 01 2022
No more hobbyist license...sad

February 12 2022
I recall that the disks failed on the public access VMS systems that included Fafner

January 03 2022
Anyone know what happened to FAFNER.DYNDS.ORG? I had a hobbyist account here but can longer access the site.

October 27 2021
Make that DECdfs _2.1A_ for Vax

October 27 2021
I'm looking for DECdfs V2.4A kit for VAX. Asking here just in case anyone is still listening.

September 17 2021
At one time, didn't this web site have a job board? I would love to use my legacy skills one last time in my career.

January 18 2021
New Hobbyist PAKs for VAX/VMS are no longer available according to reports. Only commercial licenses are reported to be for sale from HPE

January 16 2021
Can someone please point me to hobbyist license pak? I'm looking for VAX/VMS 7.1, DECnet Phase IV, and UCX/TCPIP ... have the 7.1 media, need the license paks ... thanks!

October 16 2020
OpenVMS, and this website!

September 05 2020
VSI community non-commercial licenses for AXP/IA64 are available now.

September 05 2020
See the forum about licensing. Don't know if HPE hobby licenses still being issued. Commercial licenses still being sold.

September 01 2020
I need the license for OpenVMS7.3. Where can I find them?

August 29 2020
Eisner, which is currently being moved, got an SSH update and the keys were updated to more modern encryption standards.

Shoutbox Archive