Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesFriday, January 28, 2022
Navigation
Home
Articles
Downloads
Hobby Wear
FAQ
Forums
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Search
Users Online
Guests Online: 7
No Members Online

Registered Members: 7,623
Newest Member: alleahmarcina30
Sponsors
Island Computer
View Thread
OpenVMS Hobbyist Program | VAX Systems Forums | Emulated VAX Forum
Author Vax 4000/200 VMS 5.5-2 Save_Set to SimH problem
ndfspeed1971
Member

Posts: 12
Joined: 01.03.12
Posted on March 30 2012 10:47
Hello,

I have been trying to transfer a Vax 4000/200 VMS 5.5-2 actual system to a SimH virtual machine and been having problems.

Here is what I have done so far. On the actual Vax system I created a Save_set on its spare harddrive. Then I FTP'ed out the file as a binary to a Windows PC. I took the save_set vaxdisk1.dat and created a ISO image of it and then mounted it as a rq2 CDROM to my simH. The OpenVMS CDROM backup and restore utility is mounted on rq3. I boot into the rq3 and use its utility to resore the save_set from rq2 CDRom to rq0 disk0 or the simh.

I had to create the ISO image of the save_set with the Linux terminal command dd. Here is the command:

$ dd if=vaxdisk1.dat of=vaxdisk1.iso bs=2k

Note:I am aware of the 512 block size of the FTP binary transfer to Windows therefore I chose the parameter bs=2k. Someone online suggested this.

I am able to boot into SimH with the following vax.ini file and use the backup/restore utility from OpenVMS:

**************************************************
; Load CPU microcode
load -r /home/X/software/simh/BIN/ka655x.bin
;
; Attach non-volatile RAM to a file
attach nvr /home/X/software/simh/BIN/nvram.bin
;
; This virtual machine has 64M memory
set cpu 64m
;
; Define disk drive types. RA92 is largest-supported VAX drive.
set rq0 ra92
set rq1 ra92
set rq2 cdrom
set rq3 cdrom
;
; Attach defined drives to local files
attach rq0 /home/X/software/simh/BIN/d0.dsk
attach rq1 /home/X/software/simh/BIN/d1.dsk

;
; Attach the ISO images of drives to its file (read-only)
attach -r rq2 /home/X/software/simh/BIN/vaxdisk1.iso
attach -r rq3 /home/X/software/simh/BIN/vaxvmscd.iso

;
; Attach the CD-ROM to its file (read-only)
;attach -r rq5 /home/X/software/simh/BIN/vaxvmscd.iso

; Disable unused devices. It's also possible to disable individual devices,
; using a construction like "set rq2 disable" if desired.
;
set rl disable
set ts disable
;
; Attach Ethernet to a network interface
set xq mac=08-00-2B-AA-BB-CC
attach xq eth0
;
; Now start the emulator
boot cpu
**************************************************

So, I have 2 disk drives and 2 CDRoms attached to my SimH
Disk0 rq0 Main disk that I want to copy the save_set to.
Disk1 rq1 Spare drive
CDROM rq2 has my save_set vaxdisk1.dat
CDRom rq3 has the OpenVMS utility on it

I am able to boot and get to the utility prompt and do the backup command from the OpenVMS utility:

Here is the command:
$backup dua2:vaxdisk1.dat/save_set dua0:

but I get the following error after a long time of waiting:

**********error message from termanal window**************
$ backup dua2:vaxdisk1.dat/save_set dua0:
%BACKUP-F-NOHOMEBLK, no valid home block found on DUA2:
If you do not want to perform another standalone BACKUP operation,
use the console to halt the system.
*****************************************************************

Sooooo ---->

1) Why does it still have a hard time reading the binary blocks?

2) I saw suggestions on some utilities re-aranging the block size but have no clue how to use this utility. Do you have to run this utility in OpenVMS itself as a VAX command. So, I went ahead and booted into my fresh installed OpenVMS Vax and I tried to mount the ISO image and got a error message mounting it. It said that the ISO is not Files 11 file system. Yes I know that but how do I transfer this file into OpenVMS to reconvert the block size?

Side note: I did create a full OpenVMS system install into SimH from the online documentation and I did not have a problem with the OpenVMS CD save_set image installing to Disk0 of SimH. I got to boot it and configure minor stuff. So that worked from the ISO image. Whats the difference in that?

Thanks in advance for all the help.
Jump to Forum:
Login
Username

Password



Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?

Yes

No

You must login to vote.
Shoutbox
You must login to post a message.

parwezw
January 03 2022
Anyone know what happened to FAFNER.DYNDS.ORG? I had a hobbyist account here but can longer access the site.

gtackett
October 27 2021
Make that DECdfs _2.1A_ for Vax

gtackett
October 27 2021
I'm looking for DECdfs V2.4A kit for VAX. Asking here just in case anyone is still listening.

MarkRLV
September 17 2021
At one time, didn't this web site have a job board? I would love to use my legacy skills one last time in my career.

malmberg
January 18 2021
New Hobbyist PAKs for VAX/VMS are no longer available according to reports. Only commercial licenses are reported to be for sale from HPE

dfilip
January 16 2021
Can someone please point me to hobbyist license pak? I'm looking for VAX/VMS 7.1, DECnet Phase IV, and UCX/TCPIP ... have the 7.1 media, need the license paks ... thanks!

Bart
October 16 2020
OpenVMS, and this website!

malmberg
September 05 2020
VSI community non-commercial licenses for AXP/IA64 are available now.

malmberg
September 05 2020
See the forum about licensing. Don't know if HPE hobby licenses still being issued. Commercial licenses still being sold.

silfox70
September 01 2020
I need the license for OpenVMS7.3. Where can I find them?

malmberg
August 29 2020
Eisner, which is currently being moved, got an SSH update and the keys were updated to more modern encryption standards.

jiml
July 11 2020
ssh to eisner is now giving (on linux) "WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!" , Has the server key in fact changed ? Of WHO can we ask that somewhere on the eisner webpage they

wyan
May 06 2020
Turns out I had an account here, it still was set to my location a decade ago, so hey, I'm back after over a decade!

Hein
April 21 2020
Hi all, haven't been here in years. Good to see it is all there still. I'm looking around at the forum to stop/start msipcap - 'could not be stopped' - for now. I'll shutdown FreeA

EstesDave
January 09 2020
does anyone have or know of DRB32 manuals

Shoutbox Archive