Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesWednesday, May 29, 2024
Navigation
Home
Articles
Downloads
Hobby Wear
FAQ
Forums
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Search
Users Online
Guests Online: 6
No Members Online

Registered Members: 7,708
Newest Member: nifseg
Sponsors
Island Computer
View Thread
OpenVMS Hobbyist Program | VAX Systems Forums | Emulated VAX Forum
Author Help needed installing Vax C compiler ISO using SIMH
whmacs
Member

Posts: 3
Joined: 15.04.13
Posted on May 24 2015 15:06
Hi All,
I'm hoping someone might be able to point me in the right direction. I've just installed VMS 7.3 on a Raspberry Pi 2 using Simh. I was a VMS C programmer 20 years ago and would like to give it another go. I've downloaded tbe Vax C compliler from HP's ftp site. I've burnt the files to an ISO and mounted then in SIMH as DUA3:[CC064]. The VAX can see the files however I get an error when I run VMSINSTAL saying that it is not a valid backup set. Is there anything I need to do special when I burn the files to ISO? Any help would be greatly appreciated.

Here is where I get to:

$ mount/over=id dua3:
%MOUNT-I-WRITELOCK, volume is write locked
%MOUNT-I-CDROM_ISO, CC064:UNDEFINED (1 of 1) , mounted on _SMVAX$DUA3:

$ set def dua3:[CC064]
$ dir
Directory DUA3:[CC064]
AACRT060.A;1 CC060_CR.TXT;1 CC064.A;1 CC064.B;1
CC064_IG.TXT;1
Total of 5 files.

$ @sys$update:vmsinstal CC064 DUA3:[CC064]
OpenVMS VAX Software Product Installation Procedure V7.3
It is 25-MAY-2015 at 08:40.

Enter a question mark (?) at any time for help.
* Are you satisfied with the backup of your system disk [YES]?

The following products will be processed:
CC V6.4
Beginning installation of CC V6.4 at 08:40

%VMSINSTAL-I-RESTORE, Restoring product save set A ...
%BACKUP-F-NOTSAVESET, DUA3:[CC064]CC064.A;1 is not a BACKUP save set
%VMSINSTAL-E-NOSAVESET, Save set A cannot be restored.
VMSINSTAL procedure done at 08:40
$

Regards and thanks,
Stephen
Author RE: Help needed installing Vax C compiler ISO using SIMH
Bruce Claremont
Member

Posts: 623
Joined: 07.01.10
Posted on May 25 2015 03:22
You probably need to copy the save set to disk and run a repair against it.

Here's a DCL repair procedure. My apologies to the original author, I do not recall where I obtain this:

$! RESET_BACKUP_SAVESET_ATTRIBUTES.COM
$!
$! P1 is the specification of the BACKUP
$!
$! This procedure resets the record format and
$! length attributes of a BACKUP saveset --
$! can get "broken" during certain sorts of
$! transfers -- such as FTP. This procedure reads
$! (undocumented) saveset record attributes
$! out of the target
$!
$! First render the saveset readable, and
$! check that the file exists.
$!
$ Set File /Attributes=(RFM:FIX,MRS:512,LRL=512,ORG=SEQ,RAT=NONE) 'p1'
$!
$ Open/Error=whoops/Read BckSaveset 'p1'
$ Read/Error=whoops/End=whoops BckSaveset Record
$ Close/Nolog BckSaveset
$!
$! Find the blocksize from within the record...$
$ BlockSize = 0
$ BBH_L_BLOCKSIZE = %x28*8
$ BlockSize = F$CVUI(BBH_L_BLOCKSIZE, 32, Record)
$ If BlockSize .lt. 2048 .or. BlockSize .gt. 65535
$ Then
$ Write sys$output "Unexpected block
$ Goto whoops
$ Else
$ Set File /Attributes=(RFM:FIX,LRL='BlockSize', MRS='BlockSize',RAT=none) 'p1'
$ endif
$ exit
$!
$WHOOPS:
$ Write sys$output "Error"
$ exit


Author RE: Help needed installing Vax C compiler ISO using SIMH
whmacs
Member

Posts: 3
Joined: 15.04.13
Posted on May 25 2015 17:13
Hi Bruce,
Thanks! I've give it a try tonight and let you know how I go.

Regards,
Stephen
Author RE: Help needed installing Vax C compiler ISO using SIMH
whmacs
Member

Posts: 3
Joined: 15.04.13
Posted on May 26 2015 11:09
Hi Bruce,
That DCL did the trick!. It fixed the save sets and I have now have the C compiler installed and working. smiley

regards,
Stephen
Edited by whmacs on May 26 2015 11:10
Author RE: AACRT060.A ?
cczanj
Member

Posts: 2
Location: Nottingham UK
Joined: 14.09.10
Posted on April 11 2017 11:07
I'm playing with VMS on a Raspberry Pi too. I have a simulated VAX running VMS 7.3 and got the DEC TCPIP running but it really shows its age. So I've got the Mulltinet installation kit installed on another system disk - mainly to get ssh going. I now discover that I need a DEC C runtime library package in a file AACRT060.A.

Does anybody know how to get this? I've wandered around a load of ftp sites, many of which don't actually exists any more.

Andy Jack
Author RE: Help needed installing Vax C compiler ISO using SIMH
malmberg
Moderator

Posts: 530
Joined: 15.04.08
Posted on April 12 2017 03:00
The AACRT060 kit should be included with the DEC C compiler, and if you look over the first post in this thread, you can see it there.

The AACRT060 kit is only needed for VAX/VMS 5.5-2. If something on VMS 7.3 is claiming it needs it, that is a serious bug in that software.

The AACRT060 kit is the back port of the SYS$SHAREsmileyECC$* files from VAX/VMS 6.0 to allow running programs compiled with DEC C.

Those SYS$SHAREsmileyECC* files are provided by VAX/VMS 6.0 and later.

If VMS 7.3 allows you to install AACRT060 on your system, expect problems with anything written in C.
Author RE: Help needed installing Vax C compiler ISO using SIMH
goodbyespy
Member

Posts: 19
Location: Saint Petersburs, Russia.
Joined: 17.11.17
Posted on January 07 2018 06:56
Hi Bruce! Thank you very much. I've solved the some problem.
Jump to Forum:
Login
Username

Password



Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?

Yes

No

You must login to vote.
Shoutbox
You must login to post a message.

malmberg
August 04 2022
No more VAX hobbyist licenses. Community licenses for Alpha/IA64/X86_64 VMS Software Inc. Commercial VMS software licenses for VAX available from HPE.

ozboomer
July 20 2022
Just re-visiting.. No more hobbyist licenses? Is that from vmssoftware.com, no 'community' licenses?

valdirfranco
July 01 2022
No more hobbyist license...sad

mister_wavey
February 12 2022
I recall that the disks failed on the public access VMS systems that included Fafner

parwezw
January 03 2022
Anyone know what happened to FAFNER.DYNDS.ORG? I had a hobbyist account here but can longer access the site.

gtackett
October 27 2021
Make that DECdfs _2.1A_ for Vax

gtackett
October 27 2021
I'm looking for DECdfs V2.4A kit for VAX. Asking here just in case anyone is still listening.

MarkRLV
September 17 2021
At one time, didn't this web site have a job board? I would love to use my legacy skills one last time in my career.

malmberg
January 18 2021
New Hobbyist PAKs for VAX/VMS are no longer available according to reports. Only commercial licenses are reported to be for sale from HPE

dfilip
January 16 2021
Can someone please point me to hobbyist license pak? I'm looking for VAX/VMS 7.1, DECnet Phase IV, and UCX/TCPIP ... have the 7.1 media, need the license paks ... thanks!

Bart
October 16 2020
OpenVMS, and this website!

malmberg
September 05 2020
VSI community non-commercial licenses for AXP/IA64 are available now.

malmberg
September 05 2020
See the forum about licensing. Don't know if HPE hobby licenses still being issued. Commercial licenses still being sold.

silfox70
September 01 2020
I need the license for OpenVMS7.3. Where can I find them?

malmberg
August 29 2020
Eisner, which is currently being moved, got an SSH update and the keys were updated to more modern encryption standards.

Shoutbox Archive