Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesSaturday, May 25, 2024
Hobby Wear
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Users Online
Guests Online: 7
No Members Online

Registered Members: 7,708
Newest Member: nifseg
Island Computer
View Thread
OpenVMS Hobbyist Program | VAX Systems Forums | VAX Software Forum
Author Can't install BLISS on VAX VMS 7.3...

Posts: 7
Joined: 17.08.19
Posted on September 29 2019 11:59
Hello. I only have a few months of VMS experience, so be gentle.

I installed VMS 7.3 (from HPE hobbyist distribution site) onto a MicroVAX 3100 and everything is working well. I installed C, FORTRAN, ADA, COBOL, BASIC and have been playing with each one on my VAX, it's been fun. Going through the rest of the files that HPE distributes for VAX hobbyists I saw the BLS32047.A/B save sets for BLISS. After some time online figuring out what the heck BLISS is I wanted to install it and play with it as well. I can't for the life of me to get it to installed. It's either that the files are corrupt, or I'm not setting some file settings properly. I've tried the hobbyist download site, and also freeware site. I've tried getting them to the VAX via FTP directly, via an NFS drive I have, etc. Here's my attempt and resulting errors. Happens every time regardless of how I get the files to my VAX.

$ @sys$update:vmsinstal bls32047 sys$sysdevice:[bminear]

OpenVMS VAX Software Product Installation Procedure V7.3

It is 29-SEP-2019 at 16:37.

Enter a question mark (?) at any time for help.

%VMSINSTAL-W-ACTIVE, The following processes are still active:
* Do you want to continue anyway [NO]? yes
* Are you satisfied with the backup of your system disk [YES]?

The following products will be processed:

BLS32 V4.7

Beginning installation of BLS32 V4.7 at 16:37

%VMSINSTAL-I-RESTORE, Restoring product save set A ...
-BACKUP-E-BLOCKCRC, software block CRC error
%BACKUP-E-INVBLKSIZE, invalid block size in save set
%BACKUP-E-INVRECSIZ, invalid record size in save set
%BACKUP-E-INVRECSIZ, invalid record size in save set
%BACKUP-E-READERRS, excessive error rate reading SYS$SYSDEVICE:[BMINEAR]BLS32047.A;1
-BACKUP-E-HDRCRC, software header CRC error
%BACKUP-I-SPECIFY, specify option (QUIT or CONTINUE)
BACKUP> quit
%BACKUP-F-ABORT, operator requested abort on fatal error
%VMSINSTAL-E-NOSAVESET, Save set A cannot be restored.

VMSINSTAL procedure done at 16:43

Any ideas? Clearly the file isn't what VMINSTAL wants.

Author RE: Can't install BLISS on VAX VMS 7.3...

Posts: 7
Joined: 17.08.19
Posted on September 29 2019 12:11
...and just a little more info. I also installed Alpha VMS 8.4 onto an AlphaStation and was able to install BLISS just fine using the same method of transferring the save set files from HPE.

I would say that the files on the HPE site are bad, but I get the same issue when I try to download and install from a freeware site I found and a few other personal sites where people have posted BLISS (since it's freeware I guess that's allowed). No matter where I get the files, or how I get them to the VAX it doesn't work.

Author RE: Can't install BLISS on VAX VMS 7.3...
Bruce Claremont

Posts: 623
Joined: 07.01.10
Posted on September 30 2019 02:18
$! P1 is the specification of the BACKUP
$! This procedure resets the record format and
$! length attributes of a BACKUP saveset --
$! can get "broken" during certain sorts of
$! transfers -- such as FTP. This procedure reads
$! (undocumented) saveset record attributes
$! out of the target
$! First render the saveset readable, and
$! check that the file exists.
$ Set File /Attributes=(RFM:FIX,MRS:512,LRL=512,ORG=SEQ,RAT=NONE) 'p1'
$ Open/Error=whoops/Read BckSaveset 'p1'
$ Read/Error=whoops/End=whoops BckSaveset Record
$ Close/Nolog BckSaveset
$! Find the blocksize from within the record...$
$ BlockSize = 0
$ BBH_L_BLOCKSIZE = %x28*8
$ BlockSize = F$CVUI(BBH_L_BLOCKSIZE, 32, Record)
$ If BlockSize .lt. 2048 .or. BlockSize .gt. 65535
$ Then
$ Write sys$output "Unexpected block
$ Goto whoops
$ Else
$ Set File /Attributes=(RFM:FIX,LRL='BlockSize', MRS='BlockSize',RAT=none) 'p1'
$ endif
$ exit
$ Write sys$output "Error"
$ exit

P.S. - I am not the original author of this procedure. I am grateful to whomever it was.
Author RE: Can't install BLISS on VAX VMS 7.3...

Posts: 7
Joined: 17.08.19
Posted on September 30 2019 05:06
Brilliant. Worked like a champ! Thanks Bruce.
Jump to Forum:


Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?



You must login to vote.
You must login to post a message.

August 04 2022
No more VAX hobbyist licenses. Community licenses for Alpha/IA64/X86_64 VMS Software Inc. Commercial VMS software licenses for VAX available from HPE.

July 20 2022
Just re-visiting.. No more hobbyist licenses? Is that from vmssoftware.com, no 'community' licenses?

July 01 2022
No more hobbyist license...sad

February 12 2022
I recall that the disks failed on the public access VMS systems that included Fafner

January 03 2022
Anyone know what happened to FAFNER.DYNDS.ORG? I had a hobbyist account here but can longer access the site.

October 27 2021
Make that DECdfs _2.1A_ for Vax

October 27 2021
I'm looking for DECdfs V2.4A kit for VAX. Asking here just in case anyone is still listening.

September 17 2021
At one time, didn't this web site have a job board? I would love to use my legacy skills one last time in my career.

January 18 2021
New Hobbyist PAKs for VAX/VMS are no longer available according to reports. Only commercial licenses are reported to be for sale from HPE

January 16 2021
Can someone please point me to hobbyist license pak? I'm looking for VAX/VMS 7.1, DECnet Phase IV, and UCX/TCPIP ... have the 7.1 media, need the license paks ... thanks!

October 16 2020
OpenVMS, and this website!

September 05 2020
VSI community non-commercial licenses for AXP/IA64 are available now.

September 05 2020
See the forum about licensing. Don't know if HPE hobby licenses still being issued. Commercial licenses still being sold.

September 01 2020
I need the license for OpenVMS7.3. Where can I find them?

August 29 2020
Eisner, which is currently being moved, got an SSH update and the keys were updated to more modern encryption standards.

Shoutbox Archive