Home · Articles · Downloads · Hobby Wear · Forums · Web Links · News CategoriesThursday, June 13, 2024
Hobby Wear
Web Links
News Categories
Contact Us
Photo Gallery
OpenVMS Bigot
Users Online
Guests Online: 7
No Members Online

Registered Members: 7,708
Newest Member: nifseg
Island Computer
View Thread
OpenVMS Hobbyist Program | Hobbyist Licensing | Alpha License PAK's
Author FAQ: Q)When I tried to register my PAK, the checksum failed!

Posts: 2
Joined: 16.01.06
Posted on January 16 2006 06:47
Hello, I've got an Alpha box I built myself, based around the PC164
motherboard; 500MHz, 128MB of RAM. Latest SRM console for that board.
More details on request.

I got around my issue with the serial number. I
decided to use the Tulip card's MAC address.

But I'm having this problem, to wit:

Q) When I tried to register my PAK, the checksum failed!
A) The most common reason for this is not including both
Termination and Release Dates (as shown on the PAK command
procedure as /DATE= and /TERMINATION). Enter both dates
when using VMSLICENSE and the PAK should register normally.

I'm trying to install OpenVMS for Alpha 7.2.

The install procedure asks me for most of the fields that are
provided for in the PAK, but the install does NOT ask for the
RELEASE DATE, but when it displays what I've entered, it *does*
have a field by that name, which is shown as blanks.

The install also asks for an Availability code and a Product Token,
neither of which is supplied in the PAK. When the install asks for
the product code, I entered OPENVMS-ALPHA, and when it asked for the
version, I enterfed 7.2.

Clearly I'm doing something wrong, what's the right next step?

-doug quebbeman

Posts: 1
Location: San Francisco Bay Area
Joined: 13.12.05
Posted on January 16 2006 12:36

At first glance, I would say don't enter anything for version: the version of VMS is not enforced with these PAKs (though some products are).

Though I just got new PAKS for a SIMH VAX, and the release date and termination date where set to the same date - today. So if you where setting the termination date to a year from now, which is what it should be, then validation would fail (I tried...).
Author Registering Licenses

User Avatar

Posts: 19
Location: Nottingham UK
Joined: 13.12.05
Posted on January 19 2006 11:31
Hi there,

When I registered my licenses, I simply cut the relevant portion of the e-mail and
pasted it into the DCL prompt. saved a lot of typing and avoided trouble with my
wandering fingers!!

This worked fine with my hobbyist PAKs on 7.21

Hope it helps,

Good Luck,

Author FAQ: Q)When I tried to register my PAK, the checksum failed!

Posts: 2
Joined: 16.01.06
Posted on January 20 2006 01:32

I managed to get the PAK info typed in correctly, so I'm up.

The cut-and-paste suggestion doesn't seem practical for
a first-time installation on real hardware, though I guess
that would work if installing on an emulator.

So, instead of typing in 104 layered product PAKs, can I
put the PAK file on a floppy and feed that into the system,
and if so, could someone shorten my journey by providing
the relevant magic words?

-doug q
Author Loading Licenses without lots of typing

User Avatar

Posts: 19
Location: Nottingham UK
Joined: 13.12.05
Posted on January 21 2006 23:35
Hi Doug,

Now you've got the base licenses on and assuming you've loaded a
TCP/IP stack, I can think of two possibilities here that may help and
avoid having to use floppies.

Download and install the SWB (Mozilla), forward your pak email to
a web based mail client (gmail,hotmail etc..) then you'll be able to cut
and paste. Either directly into DCL or into TPU to be able to save the
pak email as a file. - this would need you to have a graphics head on
your machine.

If you have no graphics head or don't want to install the SWB. Then you
could cut and paste the relevant parts of the email into a text file on
your PC and use FTP to transfer it onto your VMS machine where you can
then edit or run it as you like.

Hope this saves you some work.


Author Similar Problems with PAK

Posts: 30
Joined: 11.12.05
Posted on March 13 2006 22:24
I have a similar problem.

interestingly enough, the release and terminations dates sent me were both 13-mar-2007. Is this correct ?

after 3 hours last night of trying to apply the pak as part of the install, i finally gave up and let the install run through as unlicensed.

so now i have to use the license register program as follows :-


I have tried leaving information out, but always get the bad checksum.
I did register a 2nd time changing the cpu number from 1 to 2 (yeah, my machine also has no serial number) and the hardware_id changed to 2 instead of 1. Does the hardware_id make any difference ?

should i try registering with a [space] in the cpu serial number to try and trick it into a blank serial number ?

or am i missing something soooo obvious that i need to be shot ?

yours in advance

User Avatar

Posts: 134
Location: Hopedale, MA USA
Joined: 15.12.05
Posted on March 14 2006 07:13
There is a command procedure which may help (if you haven't tried it already). @sys$update:vmslicense. Take option 1 and follow the prompts to register your license.

Assuming you get the license registered correctly,
$license load openvms-alpha
and Bob's your uncle!
Author Woohoo!

Posts: 16
Location: Stonehouse, Gloucestershire, England
Joined: 13.03.06
Posted on March 14 2006 11:57
thanks for the advice brad.

didn't need it in the end. I started totally from scratch this evening, it all went on fine this time.

even managed to get it so i can browse the web with the mozilla stuff.

samba next i think smiley

Jump to Forum:


Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Member Poll
Are you going to OpenVMS Boot Camp 2016?



You must login to vote.
You must login to post a message.

August 04 2022
No more VAX hobbyist licenses. Community licenses for Alpha/IA64/X86_64 VMS Software Inc. Commercial VMS software licenses for VAX available from HPE.

July 20 2022
Just re-visiting.. No more hobbyist licenses? Is that from vmssoftware.com, no 'community' licenses?

July 01 2022
No more hobbyist license...sad

February 12 2022
I recall that the disks failed on the public access VMS systems that included Fafner

January 03 2022
Anyone know what happened to FAFNER.DYNDS.ORG? I had a hobbyist account here but can longer access the site.

October 27 2021
Make that DECdfs _2.1A_ for Vax

October 27 2021
I'm looking for DECdfs V2.4A kit for VAX. Asking here just in case anyone is still listening.

September 17 2021
At one time, didn't this web site have a job board? I would love to use my legacy skills one last time in my career.

January 18 2021
New Hobbyist PAKs for VAX/VMS are no longer available according to reports. Only commercial licenses are reported to be for sale from HPE

January 16 2021
Can someone please point me to hobbyist license pak? I'm looking for VAX/VMS 7.1, DECnet Phase IV, and UCX/TCPIP ... have the 7.1 media, need the license paks ... thanks!

October 16 2020
OpenVMS, and this website!

September 05 2020
VSI community non-commercial licenses for AXP/IA64 are available now.

September 05 2020
See the forum about licensing. Don't know if HPE hobby licenses still being issued. Commercial licenses still being sold.

September 01 2020
I need the license for OpenVMS7.3. Where can I find them?

August 29 2020
Eisner, which is currently being moved, got an SSH update and the keys were updated to more modern encryption standards.

Shoutbox Archive